Category
GAME
All Discussions DevTeam Community Read Unread
Posted by: Valkyrie Neocore 174 days ago paddlewand replied 2 days ago
Track issues directly and get feedback from the devs!
69
Posted by: Wulfenspawn 186 days ago CptWeisemann replied 4 days ago
Low framerate? look inside
3
Posted by: Slaget1 6 days ago ctiger replied 5 days ago
No Audio/Sound
1
Posted by: xssine 9 days ago xssine replied 9 days ago
The game won't start
2
Posted by: Rafe 15 days ago Rafe replied 10 days ago
single digit frame rates
4
Posted by: poetm 13 days ago Morzan replied 13 days ago
Need an 's' in Fautus to Faustus - please and thank you.
1
Posted by: Dead God 18 days ago Dead God replied 16 days ago
AMD FX-8350 + 1070GTX = Low Fps
4
Posted by: wildboy789789 19 days ago wildboy789789 replied 19 days ago
your payment verification system sucks
3
Posted by: EisenhornGregor 19 days ago ctiger replied 19 days ago
Where are my old Inquisitors ?
4
Posted by: Hashshashin 26 days ago Edinazzu replied 25 days ago
My sound is coming through choppy
3
Posted by: Gramaticus Jr 28 days ago
Weak system, performance changes without change in framerate
0
Posted by: primuspilus 31 days ago Morzan replied 29 days ago
No install button
1
Posted by: xlsangrelx 31 days ago Ixxolos replied 31 days ago
"Better performance" where? lol
1
Posted by: Mansplained 31 days ago Mansplained replied 31 days ago
Never mind. It was my GPU reaching its life span!
4
Posted by: Silk1485 32 days ago Airsick Hydra replied 32 days ago
continue bottom does not work.
2
Posted by: Affenasmo 42 days ago Affenasmo replied 42 days ago
GPU Temps off the Shard
3
Posted by: Son of Malice 91 days ago Valkyrie Neocore replied 48 days ago
There is no sound in the game.
1
Posted by: swinweflue 56 days ago Valkyrie Neocore replied 48 days ago
d3dx11_43.dll missing
4
Posted by: Roman Richter 62 days ago Megapull replied 50 days ago
ABOUT SUPPORT ANSWERING TIME
3
Posted by: Armatus 51 days ago Morzan replied 50 days ago
Beta Zugnag? Key versand?
4
Posted by: Edinazzu 52 days ago Megapull replied 50 days ago
cannot remove sigmum
3
Posted by: CR0W 59 days ago CR0W replied 56 days ago
network error inquisitor martyr
2
Posted by: Skallagrimmson 80 days ago EvilMadMonk replied 66 days ago
Inquisitor Martyr Multiplayer yet?
2
Posted by: Endymion 91 days ago Endymion replied 88 days ago
I have music but no sound, effects working in all other games
6
Posted by: Biggathanyou 121 days ago Jim Fox replied 90 days ago
problems with doqnloading and installing the alpha
8
Posted by: avatarkorki 94 days ago Morzan replied 92 days ago
bug
2
Posted by: Lobotomite 97 days ago Lobotomite replied 94 days ago
@Neocore Support Team
3
Posted by: Doc Holliday 102 days ago Kaskeria replied 101 days ago
We really can't rebind 'F' key?
2