Game crash makes entire computer shut down.

11

When WH40K crashes, it makes my entire computer shut down. It has happened twice so far, once upon entering the inventory screen and once upon trying to launch a mission.  Google shows me that some others also have this happen to them. I can send my dxdiag to anybody who may be able to assist. Thank you!

Store Page
Share
11 comments
Game crash makes entire computer shut down.
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
64 days ago
PC shutting down is normally a heat issue or dodgy power supply.

If its restarting then it could be a Blue Screen of Death, which would point to a Hardware fault.

If its restarting then you need to set it to not restart on a crash and it will tell you whats wrong.

If its shutting down then you need to check the temps and test your power supply.

61 days ago
+1

I do not believe this is a heat issue, at least in my case; my computer's temp is well-regulated.


However, I get crashes that shut off my computer as well, usually at the mission select or inventory screen.  Note that this doesn't restart, it just clicks off as it would if you switched off your power supply.(edit: power supply is new and does not halt any other time IE other games, apps etc)


I do not see anything odd in the event viewer, no record of an application error.  I looked in the log and see a bunch of json-ey looking stuff and c++ references but nothing indicating an obvious error.  Anywhere else I could look?

This comment was edited 61 days ago by Gronuk
61 days ago
+1

I've been google-fu-ing this and haven't seen many folks with this specific issue; most have been ctds or things fixed by launching as admin, updating gfx drivers, the usual suspects.

Last events in the log:

    "@class":    ".LogEventRequest",
    "eventKey":    "inventoryUpdate",
    "data":    {
        "equipment":    [{
                "artifactId":    "5ad94bc3a281700504d83665",
                "set":    0,
                "slot":    "Armor"
            }, {
                "artifactId":    "5ad94bc3a281700504d83666",
                "set":    0,
                "slot":    "Wardrug"
            }, {
                "artifactId":    "5ad92d092f253c04fb3bd177",
                "set":    1,
                "slot":    "Mainhand"
            }, {
                "artifactId":    "",
                "set":    1,
                "slot":    "Offhand"
            }],
        "inventory":    [{
                "artifactId":    "5ad92d092f253c04fb3bd16f",
                "index":    0,
                "page":    2
            }, {
                "artifactId":    "5ad92d092f253c04fb3bd175",
                "index":    1,
                "page":    2
            }],
        "seen":    ["5ad94bc3a281700504d83664", "5ad94bc3a281700504d83666", "5ad94bc3a281700504d83665", "5ad94bc3a281700504d83663"]
    },
    "requestId":    "1524190271_45"
}
2018-04-19 22:11:11.205 (3741.907s) [            26C0]      SparksManager.cpp:313      0| WebSocket callback: {"@class":".LogEventResponse","requestId":"1524190271_45"}


This comment was edited 61 days ago by Gronuk
61 days ago
+1

Trying this from this post:

Steam Launch Parameters:

  • Right click on Warhammer 40,000: Inquisitor - Martyr
  • Click Properties>Set Launch Options
  • Add: -single_core -forceservice -high  -LANPLAY -NOTEXTURESTREAMING
  • You also need to set the Warhammer_x64_11.exe to run as admin.
61 days ago
Gronuk
Thank you so much! I didn't expect it as a heat issue either as my computer is relatively powerful and can run much more (seemingly) intensive games with no issues.  I'll try this workaround and report back!
61 days ago
Canopizus

Didn't work for me.

Here are my specs:
     Time of this report: 4/20/2018, 19:25:03
             Machine name: [email protected]
               Machine Id: {the-smiling-bandit-strikes-again}
         Operating System: Windows 10 Home 64-bit (10.0, Build 16299) (16299.rs3_release.170928-1534)
                 Language: English (Regional Setting: English)
      System Manufacturer: ...
             System Model: Jugg-72
                     BIOS: 1.70
                Processor: AMD Ryzen 7 1700X Eight-Core Processor          (16 CPUs), ~3.4GHz
                   Memory: 16384MB RAM
      Available OS Memory: 16334MB RAM
                Page File: 7944MB used, 21701MB available
              Windows Dir: C:\Windows
          DirectX Version: DirectX 12
      DX Setup Parameters: Not found
         User DPI Setting: 96 DPI (100 percent)
       System DPI Setting: 96 DPI (100 percent)
          DWM DPI Scaling: Disabled
                 Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
           DxDiag Version: 10.00.16299.0015 64bit Unicode


This comment was edited 61 days ago by Gronuk
59 days ago
So verified, when on the mission selection screen(I'm only on mission 5 of the campaign), regardless of my options for missions or screen I'm on(eg. Inventory), if I hang out there too long, shuts off my pc.
59 days ago

Shuts off after ~5 minutes of being on the screen.  I found this useful bit in the logs:

The previous system shutdown at 8:45:47 PM on ‎4/‎21/‎2018 was unexpected.


I, however, did indeed expect it.

59 days ago

Finally completed opening missions on Martyr, thought problem solved, but no, starmap screen drops my machine as well.

Thought I saw something about a crash in starmap earlier but was unable to find that again.

58 days ago
+1

Hi! If you write a detailed email to the support team they will help you fix your problem. 

[email protected]

This comment was edited 58 days ago by Morzan
57 days ago

Hi, as someone before me suggested, this should definitely be a heat or a PSU issue. Try to download AIDA64 or HWmonitor to monitor temperatures and voltages, and open them while you play the game (on a separate monitor, or put the game in windowed mode). Also, if you haven't tried already so, do a complete reinstall.

Plus, you could always do the following:

  • Send us a dxdiag file
  • add verbose_logging=1 to the game's launch parameters, play until it crashes then find a warhammer.txt at documents/neocoregames/warhammer martyr and attach it here.

Thanks for getting in contact!

This comment was edited 57 days ago by Megapull