Known issues & workarounds

583

Please take into consideration that these issues do not apply to everyone, and might be unconfirmed until further testing.

PLEASE REPORT NEW ISSUES IN OUR MANTIS BUG TRACKER

V0.1.5

  • Network error
    • It is due to the transfer of the dedicated server from 0.1.4 to 0.1.5. Should be fine after a few minutes automatically
  • Crash on Heroic Deeds
    • We might silent update this
  • Item disappear bug is being looked at at the moment - since 0.1.5 we have more info about lost items, and they are not erased which means we can give them back. However, our goal is to patch this globally instead of dealing with individual user's items, which should solve all such problems in the future. Stay tuned!

V0.1.4 

  • Items disappeared for 340 people during the weekend
    • They received 10K credits, inoculator and starting gear back on empty slots for compensation
  • Co-op issues

V0.1.3.

  • Muzzle flashes behind character sometimes

V0.1.2

  • Enemies occassionally getting stuck in the wall
  • Thunder Hammer allows you to jump out of the map
  • Issues with switching/equipping weapons
  • Jump Pack missing VFX and SFX
  • Rocket Pack missing SFX
  • Thunder Hammer hit SFX missing
  • Missile backpack not showing when it is charging
  • Unable to add the game to Nvidia control panel

Working as intended (For now. This is alpha guys, things can/will change):

  • Only level 1 systems available
    • Level 2 will be unlocked in the next content update. Bear in mind that your gear is what makes you more powerful, not your ingame level.
  • No inventory during missions 
    • You should set up your gear before missions so choose carefully!
  • Mission finished window popping up after being closed
    • You are in a queue. If there is a mission result that you did not get, you should get it in the next one.
  • Not being able to unequip items


------------------------------ Workaround section ------------------------------


If your game does not start, try this:

  • Exit the game.
  • Right click on the game in your Steam Library.
  • Select "Properties" in the dropdown.
  • In the window that pops up, select the "Local Files" tab.
  • Click the button on this tab labeled "Verify Integrity of Game Cache".
  • Allow the program to run, it may take up to five or ten minutes.
  • Once it is completed, close down your Steam Browser
  •  Exit Steam completely from the toolbar.
  • Restart Steam and see if it helps.
  • Sometimes you need to do this twice because mistakes can happen during the procedure.

Additionally:

  • Make sure that your OS has all necessary updates.
  • Check if your GPU drivers are up to date

If you get a missing WMVCORE dll error on startup, install this and this - it will help.

If you can't log in, do this:

  • Exit the game
  • Hit Win+R
  • Type in regedit and hit Enter
  • Navigate to HKEY_CURRENT_USER/SOFTWARE/NeocoreGames/Warhammer
  • Delete everything there
  • Restart the game

If you are forced to create a new account even though you have one:

  • If you are asked to create a new account upon starting the game, close and exit. 
  • Open up the properties dialogue for Martyr, and enter the following as a launch option: -login %u %p (where %u is your steam username and %p is your password).
  • Start up the game again, then when the account creation popup appears, type in your account name (as it appears in the Martyr Forums) and click create. 
  • You will retain your characters but it seems that your currency defaults back to 1000 credits and 50 fate.

Removing skills:

  • You can remove any skills in the skill tree, you simply go to the end and left click then right click on the spent skill point and it should refund. 

Level 5 fate bug temporary fix:



This post was modified 1 year 159 days ago by Morzan
Store Page
Share
583 comments
Known issues & workarounds
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
1 year 185 days ago
+5
I haven't been able to complete any missions yet. The game freezes at some point during the mission (black screen, you still hear the game sounds, it sounds like something is still happening).


i7 6700, GTX 980, 16gb, nothing overlocked, Windows 10 64 bit version. Latest Geforce drivers.

1 year 185 days ago
+4
Game freezes 5-15min during mission on no specific event. Game seems to be inactive and sound loops. (couldn't finish one single mission) 
1 year 185 days ago
+3

while fighting the boss (for example Nurgle Dreadnought) the game crashes: no black screen, but picture is freezed, audio stiil playing sounds of battle, kayboard not responding, interface elements clicks has no effect (only cursor still can be moved).

----

4 times during battle, one time when hit a container

1 year 181 days ago
+3
Posted by Brujah 1 year 181 days ago
For 8 hours people have been reporting they cannot get into game due to a bug that the listed workarounds do not fix. 8 hours on a weekday, and not even a post that you guys are aware of the issue? Don't expect issues fixed on the spot, but come on.....
Unless they're based in the EU, in which case this was reported pretty late for them, well after 7-8pm I think.
1 year 183 days ago
+3
yeto

Yeah at this point from talking to a bunch of people on the Discord server it looks to be a lot of network issues causing the crashes.  But someone on Discord named Aprosule added settings to their launch parameters in Steam and I also did this and it seemed to help.  I only got crashes from weapon switching and the occasional container destroyed. But I got rid of the 10-15 minutes crashes and was able to complete missions.  Just keep in mind this is all experimental still but it improved my game for now to where I can at least play for more than 10 minutes.


Steam Launch Parameters:

  • Right click on Warhammer 40,000: Inquisitor - Martyr
  • Click Properties>Set Launch Options
  • Add: -single_core -forceservice -high  -LANPLAY -NOTEXTURESTREAMING
  • You also need to set the Warhammer_x64_11.exe to run as admin.

Again no guarentees this works but some people have reported success.  Also all credit goes to Aprosule and the others on Discord for testing these settings.



ALSO:  To the forum /webpage guys who edit the website, thanks for fixing the comment button going away for having to much text for long winded people like myself. :P

This comment was edited 1 year 183 days ago by Visorak
1 year 185 days ago
+2
noticed a slight pause when going from one section of the star map to the next the animation freezes for no more than 3/4 seconds the continues to the next sect of the map 
1 year 183 days ago
+2
Tamriel

Keep a weapon with knockback skills in your loadout. As of right now you have to knock the gate out of the green chaos aura to destroy them.

1 year 178 days ago
+2

1. All droped itemes are disapeared after finishing a mission (empty inventory)

2. All items putted in a storage are disapeared, except of starting power sword and a one green pistol

3. In one mission a warpgate can not be hited with a sword - only with shield skill (2)

4. On the "Character" tab one point is already assigned and can not be unset by pressing "-"

5. On the "Character" tab i try to assign available 4 point, but set up is not retained and all points become undistributed after a mission

1 year 184 days ago
+2
JackDaniel
Been a minute since I played I'm looking for info on loot rarity and colors but here's a link that shows the upgrade system on the unique items I was talking about. I'll keep digging to see if I can't find a rarity list somewhere.
1 year 185 days ago
+2

Still having crashes. Have yet to get through a mission without crashing. 


Description:
  A problem caused this program to stop interacting with Windows.

Problem signature:
  Problem Event Name:AppHangB1
  Application Name:Warhammer_x64_11.exe
  Application Version:1.0.0.1
  Application Timestamp:58a05f23
  Hang Signature:986d
  Hang Type:513
  OS Version:6.1.7601.2.1.0.768.3
  Locale ID:1033
  Additional Hang Signature 1:986d9e4b21945ccfc575430836b99a92
  Additional Hang Signature 2:a822
  Additional Hang Signature 3:a8226be32ffd7f8c35db80e282fe5135
  Additional Hang Signature 4:986d
  Additional Hang Signature 5:986d9e4b21945ccfc575430836b99a92
  Additional Hang Signature 6:a822
  Additional Hang Signature 7:a8226be32ffd7f8c35db80e282fe5135

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt

1 year 178 days ago
+2

Woops. No. Now every time I log in - I appear naked with all my gear lost

1 year 181 days ago
+2
For 8 hours people have been reporting they cannot get into game due to a bug that the listed workarounds do not fix. 8 hours on a weekday, and not even a post that you guys are aware of the issue? Don't expect issues fixed on the spot, but come on.....
1 year 170 days ago
+2

Item disappear bug is being looked at at the moment - since 0.1.5 we have more info about lost items, and they are not erased which means we can give them back. However, our goal is to patch this globally instead of dealing with individual user's items, which should solve all such problems in the future. Stay tuned!

1 year 181 days ago
+2

I am getting the create new account window upon loading, did the work around mentioned above and it still does not work. Like others I am plagued with the Unexpected Errors every time. 

This comment was edited 1 year 181 days ago by Betancore
1 year 178 days ago
+2
When I logged in all my gear and items are gone, when I load in a mission I saw that the potions had increased from 7 to 69 and made it unusable. When I exit the missions or complete them the gear I equipped to replace the gear I lost  also disappeared.  My Character back on the Hub he just floats around when I move him around.
1 year 181 days ago
+2
Posted by Werewolfman68 1 year 182 days ago
Has anyone figured out how to get this game to quit having unexpected errors.  I still haven't gotten to play it or get past the main screen. 

Likewise, I create an account then it pops up with unexpected error and asks to create an account.

[quote]

If you are forced to create a new account even though you have one:

  • If you are asked to create a new account upon starting the game, close and exit. 
  • Open up the properties dialogue for Martyr, and enter the following as a launch option: -login %u %p (where %u is your steam username and %p is your password).
  • Start up the game again, then when the account creation popup appears, type in your account name (as it appears in the Martyr Forums) and click create. 
  • You will retain your characters but it seems that your currency defaults back to 1000 credits and 50 fate.
    [/quote]

    This did nothing around expected error issue


1 year 185 days ago
+2
Clayment
you are one of the few, I can't even play 5 minutes without the game going into not responding mode and being forced to close it, still have yet to complete a mission...
1 year 181 days ago
+2
its alpha guys calm down, and ya there european .

btw how about a new poll: which new heros after assasine and psyker should be getting in ?.  ;-)


1 year 180 days ago
+2
Bucanneer 11

We are aware of this and other similar map related issues. Hopefully we can fix it soon, but bear in mind that it is the weekend.

This comment was edited 1 year 180 days ago by Megapull
1 year 185 days ago
+2

I haven't been able to complete any missions yet. The game freezes at some point during the mission (black screen, you still hear the game sounds, it sounds like something is still happening).

Graphic Settings on even in Low Solution drops to 20FPS. All Drivers are up to date


AMD FX 6300

MSi Radeon RX480

Windows 10 Pro / 64Bit

32GB Ram

1 year 181 days ago
+2
Kelathin
Yeah I'm having the same problem with unexpected error in regards to the account name thing.  I tried to use my name as it appears in the steam forums, but that one was too long.  I used my steam username with no success and even tried my forum name for Martyr as it suggested with no avail.  No idea what to do.
1 year 181 days ago
+2

Unable to login/Unexpected Error problem.


It's pointless trying to get this to work until the dev's have had a chance to look at the problem.  People who are unable to log in are fully aware that this is an alpha and there might be problems.  Now I'm willing to give this a few day's to see if the problem can be sorted out but if it's not, then I will be requesting a refund.    
1 year 180 days ago
+2
A few points i noticed ( im aware some are already known )


- As a crusader with the  heavy weapons expertise im still able to equip lighter weapns designed for  the Assault Gunner and Close Combat expertises  ( not sure if intended for alpha test reasons ) this seems to be the same with Crusaders with the Assault Gunner expertise being able to equip heavy weapons.


- Unable to unequip items from the inventory menu and also not being able to equip other things to replace them with ( double click and dragging )


- One handed pistol + one handed melee weapon combo seems to bug the inquisitor ( appears to be sliding instead of walking ) reverting back to a 2 handed weapon stops this and allows the inquisitor to walk again, while attacking with the one handed pistol + one handed melee weapon i do appear to do damage ( hit indicators flare up ) but no attack animations at all.


- Trying to sell one of the weapons your NEW character spawns with ( default weapons ) a message pops up saying  [unable to sell this weapon] but credits are transfered to my wallet and the item is returned to my inventory, could repeat this process indefinatly ( the items do eventually fill the vendors inventory)


- Heavy flamer has a function called [wide spray] wich doesnt seem to have an animation nor does it seem to do damage


-As of the latest update i get this error whentrying to play a mission:

CoreTech2.error

Fatal error at Gamelogic\Gamemode\Gamemode_ARPG.cpp (104)
Map config file not found: Openworld/m09


one last point is not a bug but a suggestion, i think the lascannon should overheat faster.
i could literaly walk around firing its primary shot indefinatly, the skills seem to gradually overheat the weapon properly though


1 year 177 days ago
+2

Those who have lost their gear including the weekend (including me and 340 other people exactly) have received 10K credits and inoculators already as compensation, and their empty slots will be refilled with the starting gear soon.

1 year 181 days ago
+2

So, this was quick - we have already fixed the unexpected error issue. It was a server side change so no update is needed. It should be fine now.

1 year 181 days ago
+2
Megapull

Unexpected Error Fix - Confirm working 

Thank you.

This comment was edited 1 year 181 days ago by Apone
1 year 185 days ago
+2

Game freezes and then crashes after 2-25min of playing any mission. AMD Card may be a problem? 

1 year 168 days ago
+2

Hi,


New bug found:


(Or I think this is just simply coded that way, but still needs a change)


When you approach any enemy or group of enemies, if you are out if sight or range, they will nott attack you.


Normally they will start to attack if you get in range or line of sight. (and it's happening also that way)


Issue: But if you are out of range and they still not start to attack you, but as soon you start to fire a weapon, an ability or throw a grenade, they start the attack. NOT as soon the attack hits them! No! They come towards you as soon as you press the button and the animation starts.

I think that should be changed.

1 year 182 days ago
+2
Posted by mordechiwolfe 1 year 182 days ago
Getting the same error - tried deleting the regedit entries and setting username/password as launch options.  Upon starting the game, I am required to create an account - I enter my username.  Then after a few moments I get an "unexpected error" message which eventually means I cannot start a mission - "Server refused the connection". 
Absolute the same issue. 


Tried username + password as start option but still get the "create a new account" --> "unexpected error"

1 year 183 days ago
+2

Updated with login error workaround

This comment was edited 1 year 183 days ago by Megapull
1 year 182 days ago
+2

Every time I try to join a mission I get "Server Refused the Connection" I have tried switching planets and systems nothing seems to work.

1 year 183 days ago
+2

Updated with fix for force account creation. Minor update is here soon, slightly bigger one on Friday.

1 year 184 days ago
+2
Updated. Inventory not being accessible during missions is an intended feature, you should set up your gear before a mission.
1 year 176 days ago
+2

I wanted to be sure to mention that I am still experiencing the following:


-Items disappearing (it can happen when I crash as well as even if correctly log out of game to then later return to find items gone)

-Muzzle flashes behind character sometimes (I still see this happen)

-Bunker busting crash (I have not been able to load a single Bunker mission; all crash)

1 year 183 days ago
+1
Tarik Torgaddon
Yeah, i am havinbg the same problem, whenever i try to equip any blue or green close combat weapon or pistol i end up without any weapons in the first slot.

I assume i can only equip common weapons for now ??

1 year 183 days ago
+1

Hello neocoregames!


To begin with, the game is very cool. Thank you! The first, and not a very nice bug - a repeated crash the game. On the mission observed that the shots go through some of the wall / fence, which should not be, is not destroyed partially or completely. Also not quite enjoy the game optimization. It must be something to do with it :)

Hopefully we, the participants of the alpha, beta test, will be able to assist you in a speedy finalization of games.


Sincerely, Tamriel.

1 year 185 days ago
+1
Already posted this elsewhere, but to make it easier to find:

- Close button from the SKILLS menu doesn't work for me (all others are fine). Not a major issue, but I guess it should have a pretty easy fix, too.

1 year 183 days ago
+1
Posted by Dragonsblade71uk 1 year 184 days ago
Can`t see it mentioned. Turrets are not despawning. So you can have 3 turrets out, all over the map, and that means you can no longer spawn them when needed.

Either this is intended, but during place I have had them despawn (Not from being killed), and been able to place elsewhere.

So its either bug, or the skill should show a counter like grandes, if its a limited use!

We should be able to recover those turrets after your done with a fight. I dont like having to wait on them to either despawn or get destroyed. Hopefully this gets  looked at.
1 year 184 days ago
+1
Posted by Azezealk0RD 1 year 184 days ago

Is it intended that Blue Tagged Items are uncommon and Green Tagged items are rare.

From what I've seen All blue Items have 2 Modifiers on them all Green Items have 3 Modifiers on them.

Some clarification would be nice as the previous....well forever of RPG/ARPG etc has always been Green is uncommon and Blue is rare. if thats the way you are going then Cool Cool, I'll just need to rewire the brain

I've posed this problem as well - I wanted; white -> green -> blue -> purple -> yellow/orange (MMORPG style)

Until I remembered what it is like in Diablo III; grey -> white -> blue -> yellow -> orange -> green


So I guess it's as you say, a rewiring of our brains :D I kinda like it!

1 year 183 days ago
+1

At the moment, I can not pass the mission Nurgle infestation. I can not break the warp gate. One of the three I've broken, but the other two can not be killed, as they restore his health equal to my damage.

This comment was edited 1 year 183 days ago by Tamriel
1 year 185 days ago
+1
Game goes Black screen after a few rooms of a mission, Still have sound game sounds like its still running fine except its stuck on whatever mouse button i was holding


Drivers all A-OK

Done a full reinstall and a few other bits and pieces

1 year 184 days ago
+1
Posted by Megapull 1 year 184 days ago
Indeed. To be honest, I want total and free access for the entire inventory, it would be good for the game.

I agree - being able to adjust as you go along would be nice. One could argue that of course the character can equip what he finds, but not bring any items other than the equipped ones.


Make the inventory available during missions, but any items in the inventory when going in should be 'hidden' - this way you can't bring every gun and adjust, only if you find a new gun in the mission you can adjust with that gun - or whatever item you find.

1 year 184 days ago
+1
Megapull
I can see the reasoning behind "locking" out the Inventory In mission but there is a balance to be had in still being able to see/access parts of it Without being able to Retool/Requip


1 year 185 days ago
+1
Game still hangs about 5-10 mins in for me, all drivers are up to date.


System is I7 6700k, 32 GB ddr4 ram, Titan X video card.


Smooth gameplay till the hang happens.

1 year 185 days ago
+1
Hi!


As many others, Snakefist too suffers from random crashes (hanging). Few notes - between 0.1.1 and 0.1.2, memory usage increased dramatically (was ~1.3-1.7Gb, is 3.7Gb). Engine uses some of the cores constantly, even when minimized (on my aging rig soon-to-be-replaced(TM) fully, 100%).


Rest is the same as was reported by others; so it's seen on rather different configurations. 


Will be a great game when this is solved...


Best of luck, 

Snakefist

1 year 175 days ago
+1
My inquisitor get naked again. Loose all the equip. now dress a nice tunic.........In the name of the Holy Inquisition back all to me or die heretic smugglers of Hell.
1 year 171 days ago
+1

it is impossible to sell the equipment when the available space is over in the store


1 year 182 days ago
+1

So, forced to create a new account even though i allready have one:

- Setting up Launch Options: -login %my Steam account name %my Steam account password (should we use the '%' symbols please?)
- Ingame: Creating new account: my Neocore account name (should we use Capitals only please?)
Tested multiple combinations of the Account names/Passwords, couldn't figure out the right one yet. Verifyed game integrity, seems good.
Can anyone please lend a heads-up?

1 year 185 days ago
+1

ive had game freezes due to various things, some i dont understand and others i know from the action i was just doing. so with that ill list off my freezes as they happened to my actions;


froze when pressing/holding shift to stand still and fire - this has happened 2 times to me

froze while i was moving through the map - 2 times

froze trying to open chat - new today. only once so far

froze while switching weapons - only happened once so far.

1 year 183 days ago
+1
Items gone.

Change some equipment and when i start mission secondary weapon wich i changed is just gone, leaving mission and whai see, half of changed items is just gone.

Tried few times and same problem.