2.0.0.b Bug Listing by Steel


The game has since been patched to 2.0.0.c, a new post is tracking current bugs at that level. Please don't post anything new here.

PC Version,

Moderators, please feel free to help me mark resolve or direct me to a more official bug compendium as these may become harder to track over time (Fixes, falsely reported bugs, etc...)

1) Receiving Morality, Ancient Relic & Archeotech gear with no extra stats/attributes for the exception of the base stat (And the extra Archeotech bonus affix). An example is an archeotech seal which only has suppression resist, nothing else (This was even more strange as it even lacked an Archeotech bonus). Got an ancient relic eye implant which only had adrenaline on it. Incase level matters, I started to see this is level 69.

2) When re-rolling enhancements on gear I've rolled the exact same affix with the exact same roll. I thought this was terrible luck but I proved on 3 items I can re-roll 5-10 times and I get charged resources but the affix never actually changes.

3) Some modifiers added by the Tarot cards are showing code variables versus the intended out. 

'{Physical_resist}% physical resist to medium enemies and groups contain one additional medium enemy'.

'{warzone.handicaps.Tarot_Posessed_1.desc.desc'  Hehe, insert comment about copy.final.final_copy.version2.


4) (Resolved by 2.0.0.c) In a Void Crusade I have a mission which always crashes the game once I start the mission (When I click the actual 'Start' button I immediately receive a bug report). It's the 4th (Upper left of the fist 'V' path) mission when taking the left most path. I enhanced it with 3 Tarots of The arch enemy, Superstition and Venom. It's a 'Secure the artifact' mission. If I take a different path/mission, the new missions load just fine.

Can confirmed on another Void Crusade this mission did the same thing without any Tarots cards enabled. At this point I can't do more than 3 missions on the left branch of Void Crusades. This is rather disappointing as it has the most missions.

5) It's common for turrets to double up on the same location. I kill a turret and then another magically spawns on top of it. I've only seen a 2nd turret spawn so it's not infinite or anything.

6) Possibly due to explosive effects, some corpses are getting attached to the ceiling/sky.

7) 'All melee enemies count as Armoured and gain +x% Damage Bon' negative modifier from a Tarot card doesn't correctly wrap in the mission briefing screen.

8) If you die after completing the last mission in a Void Crusade all you can do is 'Esc --> Abort Mission'. Your not prompt with a 'Mission Failure' Or a spawn into the Treasure area.

9) (Resolved, 2.0.0.c) A rectangular chest with an aquila and a heavanly light shining upon it shows up rather often but isn't ineractable and doesn't contain loot. The object clearly appears to be a loot chest but is deceptively setup as terrain. Can't tell whether the chest is bugged or it's part of the environment.

10) The Tarot modifier 'Upon death enemy has a 25% chance to spawn a daemon' is really 100% chance upon death. Also, the postuals nurglings spawn from always spawn a Plagueridden Medium Nurgle enemy. Not sure if that was intended but certainly makes for an interesting encounter.

11) On the 2nd Middle (straight up the middle) Void Crusade mission (It's a Siege mission)  it's possible for the guardsman to go invisible. Not sure what caused it yet.

12) Map rendering doesn't look correct on a Void Crusade mission, (1st mission straight up the center of the mission selection). Hit 'm' to bring up the map and it's painfully obvious 1 of the 4 map sections is wrong.

13) The most northeastern hound pack in a Void Crusade mission, (1st mission straight up the center of the mission selection) isn't ideally placed. A few hounds in the pack always spawn stuck behind some rocks and unable to escape.

14) A stack of 20 Intel changed to a single Intel while in Storage. I had completed a stack of 20 and started a 2nd stack. Upon relogin an hour or so later I noticed the stack I was adding to was at ~3 while the original 20 stack changed to 1. It's possible this is a non-issue and it's intended for Intel to disappear after 48 hours but I think it may be a bug in which if one in the stack expires, you may loose the entire stack.

15) (Resolved, 2.0.0.c) The Tactical Map during Intel Mission Briefings doesn't always line up horizontally leaving a slight 'staircase' effect. The offset makes the map look a bit ugly.

16) Death cult blade received a Relic bonus which the variables were present instead of the intended text. 'Critical hits restore {nembonusz_artifact_enchantment,100} of your maximum hp}.

17) (Resolved, 2.0.0.c) The XP rewarded at mission success doesn't accurately reflect what your XP bar receives. You can record your in-mission XP just before mission completion and the XP reward is always larger than what is actually rewarded. At level 75 I'm seeing a shortage of about 5-8 thousand experience. This is with a Meme virus enabled and several Tarot cards activated. Not sure if XP is being lost or the XP reward summary math is wrong. I had suspected this was meant to reflect the total XP earned during the mission (from kills) and the mission XP reward from the mission briefing combined but these two don't add up either as I had the end reward indicate ~18K but I made ~24K from start to mission end.

18) (Resolved - Working as intended) When upgrading a Tarot card such as Resilience, the lvl 1 card provides +40% All reward &  Increased chance to gain high quality item (Relic or higher) but nothing on the Tarot card changes (In terms of the reward text). Not sure if the upgrade is bugged, or the unknown chance to receive a high quality items increases (Or perhaps the Hazards become less hazardous?).

This is a non-issue but rather an enhancement it appears. The 2.0.0 release notes indicates what happens at each level but it would be nice for the Tarot card text description to reflect this as upgrading the card show no changes short of adding a skill icon.

19) (Resolved - Working as intended) Received a Signum with both Critical hit strength and Critical damage making me realize I have no idea what the difference is. Not sure if there is a bug here is terms of the attribute being renamed or there is some actual difference. The Character screen does not display/explain Critical hit damage.

20) (Resolved, 2.0.0.c) When re-rolling the base attribute of an item (Damage for weapons, Max Health for Implants, etc..) the Modify Base Attribute always says 'damage' and isn't updated respective to the items base attribute. It should say 'suppression' for Neural implants,  'Adrenaline' for eye implants and such.

21) (Resolved, 2.0.0.c) The when your character enters an enraged state, the status icon is labeled 'buff_enraged_state' when you curse over it.

22) The level 2 Tarot Card 'The Crucible' increase Glory Rewards by 200% (In addition to the +30% to all bonus). The math appears to be wrong as a Void Crusade mission offering a base of 56 glory is increased to only 102 when you add this Tarot card.

----- After first Moderator response -----

23) The Psalm combination 'Nova Psalm + Volkite Psalm + Transonic Psalm' correctly updates a 3 socket Powersword (Hurray!) but the combination effect 'Killing a Shocked enemy creates an explosion causing Shock and dealing damage equal to Damage from the killing blow' doesn't work. I've confimed very slowly (in distortion fields) killing a shocked enemy has no nova effect nor damage anything (enemy or terrain) around the immediate target.

This post was edited 3 years 228 days ago by Steelpain
Store Page
2.0.0.b Bug Listing by Steel
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
3 years 228 days ago
It fixed quite a bit based on what I tested after the maintenance window, thanks for doing such a great job all!
3 years 229 days ago
Patch 2.0.0c should have fixed the chest issue, please check on it!
3 years 229 days ago

I took all of the consumables out and it didn't crash. (I missed a stack of Destruction Amplification the first time).

If I get the turrets again, ill look for a terminal. I didn't see one last time.

Yeah, number 4. (I shouldn't reply after a 10 hour workday! :(( )

I am getting un-clickable chests in almost every mission. The long thin ones that have a chance to drop loot or turrets.

This comment was edited 3 years 229 days ago by Kalenath
3 years 229 days ago
Thank you! Looking forward to the upcoming patch notes. let us know if there is any kind of 2.0 bug compendulom to track (and report bugs to).
3 years 229 days ago

We are working on the issues, some have been fixed already, others are still under investigation. Thanks for the detailed report, much appreciated!

Critical damage is different than the Critical Hit Strength - it multiplies the overall damage you inflict by the given percent

This comment was edited 3 years 229 days ago by Marcopolocs
3 years 229 days ago

I don't believe it's stacks of consumables as I can sort my inventory and I have those as well. I haven't experienced a crash due to sorting yet but I started 2.0 at level 68 and since then I'm 79 and have pretty much deleted everything from my inventory except for consumables and new gear.

My recommendation is to remove everything old as you should be getting better gear from leveling. My guess is something got changed/renamed in-game but was missed on an item in your inventory and that is breaking the sort but again, just a thought and not confirmed.

IF you have spare time, you could empty your inventory and see if the sort works without crashing. If yes, start placing item back slowly until the sort crashes your game. Eventually you'd find the offending item.

3 years 229 days ago
Kalenath, do you mean a mission with 3 turrets each with a green '!' over them? If so, there should be a terminal in the room which you inteact with and once you've done that, they become your ally.

Your secure thereilc always crashing I've reported at #4 in the list, this happens to me as well.

3 years 230 days ago

Also: Got some ODD things in Void Crusade a moment ago.

1) Turrets with (!) over them that are not interactable with. Maybe for the expansion?

2) Secure the Relic mission in Void Crusade crashes the game every time I try to play it. Probably something from Prophecy?

I tried to order my inventory by rarity with none of my consumables in the stash and it still crashed the game, so it likely isn't that.

This comment was edited 3 years 230 days ago by Kalenath
3 years 230 days ago

Not sure.

It might be the stacks of Survival Enhancements or the other consumables. I did not even realize those could be stacked until after the first crash.

I will experiment later.

The thing is, many people are expecting Neocore to have the staff, funding and time allowable of a AAA company like Bungie or Ubisoft. That is ridiculous. We are beta testing this. This is WHY they postponed the release of Prophecy, so they can find and hopefully squish many of these annoying bugs. The update they made fundamentally changed a LOT of stuff and broke a lot of things.

We have more eyes, ears and hands on the problem than Neocore can possibly have. They need information on what is wrong or they will likely focus on the wrong things to fix.

Yes, it is annoying. I fully agree, but I REALLY think this game still has promise. Maybe that makes me a naive, silly fanboy? Maybe not. I am still on the fence as to whether or not I will buy the expansion but I am liking this update. The Void Crusades are cool.

This comment was edited 3 years 230 days ago by Kalenath
3 years 230 days ago
Strix Amko
I got this bug! Once in a while after a mission, all the loot I got during that mission is gone from my inventory...

I've lost a good flamethrower because of that. It happen quite often to make it worse.
And obviously, It does put a burden on my ability to get credits be selling stuff.

3 years 230 days ago
Really hoping a Developer / QA Member see this post and replies. I'm really enjoying this update and am only trying to assist the community.
3 years 230 days ago
Interesting, can you think of any particular item in your stash which the update may not like? Have you tried removing some/all and seeing if the sort works?
3 years 230 days ago

I have seen these and another fun one on PC:

Every time I try to sort items in my stash, it crashes to desktop. Every time. I guess I should assume that 40K does not like organization?

This comment was edited 3 years 230 days ago by Kalenath
3 years 231 days ago
all true nothing different on lvl 85.... same bugs same stuff .... i told them to release beta before going live....and now this is what they get...cccccc ... im soo angry