Inquisitor Martyr

17

Game won't launch. Click play, nothing happens. 

This post was edited 1 year 246 days ago by Voarag
Store Page
Share
17 comments
Inquisitor Martyr
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
1 year 246 days ago
I have the same issue.  I try to launch from the folder and get this :


"The program can't start because D3DCOMPILER_47.dll is missing from your computer. Try reinstalling program to fix this problem."


If the devs see this, please help. I'm wary of downloading dll from random websites.

1 year 246 days ago
I don't even get an error message. Just fails to launch. 
1 year 246 days ago
Posted by Voarag 1 year 246 days ago
I don't even get an error message. Just fails to launch. 
Yeah if you launch from steam there's no message. But opening from the game's folder gives the message. I'm verifying the folder integrity atm just see if it does anything
1 year 246 days ago
Confirmed, get that same error when launching from folder. Verified integrity earlier so that likely won't help. 
1 year 246 days ago

Same here. Verified integrity just now. Nothing.

1 year 246 days ago

Did a search and the required file is present on my compy. 

1 year 246 days ago

Sad, well I'll be playing Eternal Crusade until this gets looked at 


1 year 246 days ago

Renaming the *46.dll in the game folder to *47.dll has allowed the game to launch. Will advise if it crashes as I work with it. 

1 year 246 days ago
Voarag
I also found the missing 47 on my computer and copied it over.  Now it's missing a different file, one I don't have elsewhere.
1 year 246 days ago

After renaming the file; game launches but results in a "network error" message from in game. 

This comment was edited 1 year 246 days ago by Voarag
1 year 246 days ago

I have tried starting the game. Neither desktop shortcut or the Steam " Play " button produces anything other than the small Steam window stating the application is trying to start for approximately 2 seconds and then the window disappears with no further action. All files validated with the 5.3 gb update performed.

32 gb ram
FX 9370 CPU 

Radeon R9 390 4GB Video

This comment was edited 1 year 246 days ago by Kriegwulfe
1 year 246 days ago
Posted by Kriegwulfe 1 year 246 days ago

I have tried starting the game. Neither desktop shortcut or the Steam " Play " button produces anything other than the small Steam window stating the application is trying to start for approximately 2 seconds and then the window disappears with no further action. All files validated with the 5.3 gb update performed.

32 gb ram
FX 9370 CPU 

Radeon R9 390 4GB Video

Same Issue. Trying to launch it from the steam library folder tree says,

"The program can't start because D3DCOMPILIER_47.dll is missing from your computer. Try reinstalling the program to fix this problem."
Validating files was successful. Still same issue.

This comment was edited 1 year 246 days ago by Kaithor
1 year 246 days ago
I tried a full uninstall and re-downloaded the game. No change. 


1 year 246 days ago
Kaithor
I had to download the d3dcompiler_47.dll and then put the file in the folder 


steam>steamapps>common>warhammer 40,000 inquisitor - martyr

Doing this got the program running for me. I did get one network error message but I quit the game and then restarted and then selected the run game from the steam library drop down menu and the game fired right up. I hope this helps some.

1 year 246 days ago
Kriegwulfe
Tried this and got another error. Can you post where you got it from?
1 year 246 days ago
theformula

if you rename the "D3DCOMPILER_46.dll" to "D3DCOMPILER_47.dll" it should work, found in another post and worked for me hope that helps.

1 year 239 days ago
Hallo, i got this game yesterday and have problems with strat any mission. I can see all planets but cant start any of them... I get an OpenWorld error from my game files. I had to try reinstal the game in steam and cant install it again... Dont know what to do. It says i can only read the game documents. not possible to use the game key twice :(