Imperiall

10

Purchased the imperial edition just litterally a hour ago and tryed loading the game only for a error message to pop up saying cannot acesses neocore servers i need answers from this site as i just spent 31 dollars on a non working game , feedback ASAP is appreciated.

Store Page
Share
10 comments
Imperiall
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
170 days ago
+1
Marcopolocs
Great news man, game is offically up and running thank u and ur staff so much for fixing the issue, I look forward to spending hours and hours on this game
170 days ago
Posted by Marcopolocs 170 days ago

We are still working along with Sony on the matter! I will keep you updated here! 

Alrighty I look forward to hearing from u,with some good news lol
170 days ago

We are still working along with Sony on the matter! I will keep you updated here! 

171 days ago
Marcopolocs
No change on my end boss, still pops up with the same message u said sony issued a update wouldn't that pop up under newly updated or some kind of message so we know to update the game ?
171 days ago
Posted by paininhead 171 days ago
Still not working. How much longer will it take? How can we get a refund?
Same for me I just got on and it's a no go
171 days ago
Marcopolocs
Still not working. How much longer will it take? How can we get a refund?
171 days ago
+1
Marcopolocs
Thank sir at work at the moment but rest assured I will be trying it when I got,home :)
171 days ago
+1
JaySerrano

We would like notify you that Sony issued a system update and according to feedback we collected and as we also experienced this on our end it seems it has resolved the connection problem. Please launch the game when you got some time and check on it. In case you still experience any error please get back to us! 

This comment was edited 171 days ago by Marcopolocs
171 days ago
Marcopolocs
Thank you for ur quick response ,I'm really hoping it will be restored soon ,nit for now I'll keep my fingers crossed 
171 days ago
+1
Hi,

we are investigating the connection error and will restore it in the shortest time possible!