Feedback and bugs


My initial thought/bugs after an hour of play:

I feel like the jump animation for the melee crusader is very odd. Hopefully this is just because the animation hasn’t been done yet.

The crusader (probably all characters) seems incredibly powerful when considering the lore. Not sure the average inquisitor could take on a room full of plague bearers and a dreadnought.he also feels a bit (attacks and walks) like he should be in terminator armor instead. May help with the question of why he can tank so many enemies.

Not all enemies fall over when dead. Lots of plague bearers standing upright after I killed them.

On one Hunt mission after killing the dreadnought the warlocks in the room didn’t attack me. This happened in other rooms though other enemies would still attack

Melee Crusaders jump often (always)  overshoots targeted enemy.

Flamethrower audio plays over for a while after the enemy is dead

Needs a buyback or sell back option. Purchased an item by mistake (no explanation of r-click l-click to view or buy) and could only sell back at a fraction. Did seem to be able to buy it again for the sell price.

Equipped new Power sword and it floats above hand like a gun then when used in combat there is no attack animation it does damage to enemies that I am close to as expected.

Character often gets stuck when trying to pass find around in the me characters.

Game Crash when destroying exploding terrain around several enemies. after closing and rebooting my computer I am locked out of the game due to it believing that I am still logged in. This seems to be where I will end for the night as I cannot log back in.

This post was edited 7 years 153 days ago by fiyga
Store Page
Feedback and bugs
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
7 years 153 days ago

The Skill menu can't be left by the close button. I have first to switch to deeds or inventory to leave the screen.

A window to compare an equipped item with an item from store or inventory is missing.

Chat window vanishes very fast, chat options are not accessible.

I don't know if it is intended, but the inventory isn't accessible in a mission.

And... posting longer comments is arduous because the text box window doesn't scale correctly  and the "Comment button" vanishes. Using the mouse wheel results in scrolling the whole thread windows. Al in all, i got a few problems navigating the forum and comments.

7 years 153 days ago

I equipped my crusader with 2 pistols. After a Mission i tried to change it back to a gun but couldn't unequip the pistols.

Switched movement controls to wasd and tried to set another key to switch weapons without any effect. The switch weapons button in the HUD states that the W is still bound to it.

After completing my first mission on Aethon Prime the game stops and doesn't react anymore. After Crashing the game and restart the game showed the mission results, kill numbers etc. After my second mission on Aethon Prime the game crashed again. Restarting it this time no mission results where shown my loot is gone and the merc doesn't offer any goods. Restarting the game, still no goods.

When selecting an item in the inventory the focus box is shown above the item. The skills in are also of focus and below their boxes.

7 years 153 days ago
Thanks for all the detailed feedback ! Some issues are already known and being worked on - the rest was very useful info too!
7 years 153 days ago
I noticed the same with the enemy not falling over. I tried to take a picture but the stem screen shot key did not work, and alt tabbing made the game crash.

After which I also got the already logged in message.

But the game looks great.