The electric arc on hit effect no longer works when fighting single enemy(Patch 2.4.1)

5

It seems that  the effect on construct module : "electric arc on hit"  has some bug after the patch on 8.12.

The effect cannot activate when the constructs face single enemy (still works when fighting groups of enemies).

This effect works normally in a video recorded in 8.9, so we suspect this bug was introduced in patch 2.4.1.

This makes vivisectors powerless in Boss battle.

Please look into it and see how this could be fixed.

Thanks :)

This post was edited 6 days ago by Distemper
Store Page
Share
5 comments
4 days ago
Marcopolocs

Hi :


We believe we have some proof here:


https://drive.google.com/file/d/1s23KVfbd3fJVDI2gIms9FYQqVWHDyoet/view?usp=sharing


Please see the two comparisons in this video above:


1. At 1:05, 3 constructs faced 2 enemies, and the construsts concentrate the attack on one of them.


We could see the damage number on the first enemy : 155 for each attack. No higher values.


But for the other enemy who's NOT directly attacked by the constructs, he receives larger damage values (995) from the electric arc, and he actually dies faster than the guy who's under direct assault.


We consider this to be proof that the electric arcs are not damaging the first enemy on whom the effect activates.


2. At 1:40, 3 constructs faced groups of enemies. At 2:05, 3 constructs faced one enemy.


The battle efficiecy is considerably slower in the latter case. (Even considering the fact that the enemy is a champion, his HP drops very slowly, not like what was observed just before)



3. There's also some screenshots from videos recorded before the 2.4.1 Patch:


https://drive.google.com/file/d/1WKhQvSxnVx6nwrEfRLJ3rUEvlWDnrM-M/view?usp=sharing


The mission levels are higher (Lv118) than the video above(Lv110), yet the constructs could deal higher damage during single enemy battle.

The construts weapons are below Lv100, so this cannot be explained by the recent high-level weapon bug.

The screenshots are from :

a video at 7.24: https://www.bilibili.com/video/BV1a54y1E7x5/

a video at 8.7: https://www.bilibili.com/video/BV12o4y1m7RJ/

(I'm not sure if you can reach these videos, just put the sources here)



ID of the kind player who provides all these videos: Leieisw


Name of the character he used in this video is in the screenshot zip package. I have asked him to keep his equipments unchanged for a while, in case if you would be interested to test his character.


Thanks for the help !

4 days ago
+1
Distemper
I would be surprised if it were to be broken as we tested the effect yesterday to confirm the bug you reported. :O 

Strange. Please share the video when it's done. Thanks in advance!

4 days ago
Maybe we could prepare some video proof later, I'll be back then
4 days ago
Marcopolocs
Sorry for the confusion before, what we found is that the visual effect is still there, but seems it no longer causes damage when fighting only one enemy (still applies shock effect but no damage). 


Is this still the intended behavior?

5 days ago
That huge visual effect was modified but as we checked in the live version just now it still works as intended.