Still unable to add the game to nvidia control panel

9

I've use right click and run with NVIDIA graphics card to run the game properly - but that doesn't make the GPU the default (clicking the steam lauch button reverts it to running on the integrated GPU)

I can set the default GPU to my NVIDIA GPU, but that means that I can't run other games stable.

Any chance you are looking into fixing not being able to add the game to the NVIDIA control panel?

This post was edited 1 year 184 days ago by Game kNight
Store Page
Share
9 comments
Still unable to add the game to nvidia control panel
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
1 year 130 days ago
+1

Disregard my last post I can't find the edit or delete button.  I want to specify in my instructions.


If you remove the comma from 40,000 to Warhammer 40000 Inquisitor - Martyr in the game's folder name.  It allowed me to add Warhammer_x64_11.exe in my Nvidia Control Panel and play the game with my Dedicated GPU.   It screws with the dir. path name but it works.  More importantly I think it's the key to help Devs provide a proper fix.  The older WH40K use the comma without any issues.

1 year 130 days ago
Megapull

I would like to add that if you remove the comma from 40,000 to 40000 in the game's folder then run the game, and exit.  It allowed me to add the game to my Nvidia Control Panel and play the game with my Dedicated GPU.   It screws with the dir. path name but it works.  More importantly I think it's the key to help Devs provide a proper fix.  The older WH40K use the comma without any issues.

1 year 177 days ago
Megapull
Not working for me, there is no way to add it to nvidia control panel that I can see
1 year 183 days ago
Awesome to know you're looking into this! Happens to me as well, hopefully this will help the performance for me. :)
1 year 183 days ago
Megapull
Thanks, man - you're the best!
1 year 184 days ago
+1
Game kNight
Okay, I have already added this to our bug tracker, let's see what we get :)
1 year 184 days ago
Megapull
Yeah this is what I do with every game that starts out using my Integrated - it's nothing new, it happens all the time.


The problem is, that when I pick your games .exe file - it doesn't show up on the list. Hence I can't pick the NVIDIA GPU.

I've never experienced this problem before, so I'm guessing it is in your code somehow :)

1 year 184 days ago

So by your description it seems to me you have tried this, but I'll post it anyway:

  1. Go to the NVIDIA Control Panel by right clicking on your desk top and clicking on "NVIDIA Control Panel".

  2. In the default screen that pops up (it should be "manage 3D settings", and the "Program Settings" tab should be automatically selected), under "1. Select a program to customize:" hit the "Add" button.

  3. From here, navigate to the folder where your steam games are located. For me, it is C:\Program Files (x86)\Steam\steamapps\common.

  4. Select the folder for the game you want to use your NVIDIA card for, and find the .exe for that game (it's usually right in the main game folder). Select it and hit open.

  5. Then, under "2. Select the preferred graphics processor for this program:" open the drop-down menu and select "High-performance NVIDIA processor".

  6. Finally, hit apply in the far bottom right corner, and you should be good to go!

1 year 184 days ago
Thanks, I'll look this up and add it to our bugtracker.