Memory leak PC back again with path 2.4.2c

5

Hi,

Appears there is another memory leak with 2.4.2 patch. 

Thre was one earlier in the year that got fixed: https://neocoregames.com/en/community/hub/performance-issue-mem-leak-micro-stutter but now it's back.

Steps to reprouce:

  1. Go to mission
  2. Stay in missing for 60 minutes or more
  3. my memory usage changed from 2.5Gb to 14Gb in this time
  4. Note. The leak is slower if you finish missing and go to next one. 

Hope you will managed to get it patched as sadly game is no playable like this (again :( )


Update1.

1. It does not seem to be happening all the time. Not really sure how reliably reproduce. Will report if I will find out. 

This post was edited 50 days ago by Denatare
Store Page
Share
5 comments
Memory leak PC back again with path 2.4.2c
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
40 days ago
Denatare
Your character was copied and we sent it to the testers to check on the Armour. Thanks for the further details. Nice catch!
44 days ago
+1
Sure thing.


Account name: Denatare

Character name: Dante

the armor is in character inventory, third "tab" all the way in the bottom right corner. 

48 days ago
Denatare
Wow. Could you tell me your account and character names? I would like to have a look at this armour.
50 days ago
+1

Update 2. 


I think you were onto something Marcopolocs. And thank you for reply!

Been experimenting with this last few days. 

First I noticed on Assassin there was no leak, then back on my Heavy Gunner and had memory leak even without leaving the ship. 


What I noticed it was one particular Demoliton Armor that is causing the problems (picture attached). 

  • With this armor equipped - memory leaking. 
  • I remove the armor it stops or even get cleared with time ( mem leak that is )
  • I equip the armor again - memory leaks again
  • Equippming almost identical Demolition armor, but a separate item, no leak

Very strange but easy to work around by just swapping armor. Posting here in case it will help others. 


You have mentioned problematic asset which it seems to be the case. What does it mean if you do not mind explaining? 




Thanks again. 



52 days ago
Probably it is related to particular map settings? My primary guess would be a problematic asset but to find it we would need more clues. Please let me know here if you found something specific.