Intel Ordo rep working properly?

2

https://neocoregames.com/en/community/warhammer-40k-inquisitor-martyr-compendium

Tip: All Intel missions have a 33% chance to add Ordo reputation to the players, depending on the enemy type.


I've just gone through 10 or so Intels, yet no Ordos rep in sight.

The funny thing is, the first few missions, I was getting 50% or more of my Intels with rep rewards, but now, nothing.

Could this be a bug? Works at first, then RNG drops to 0?

EDIT: I just created an Intel mission, and I got an Ordos reward. Seems like only the auto-generated Intels give no rewards after the first few missions.

EDIT2: Similar thing happened. After I got a few Ordos Intels by starting my own (using my Intels), I then got 0. This surely must be a bug. It's not even close to 33%. It's more like 50%+ for a few, then ZERO for the next million (or so it seems).

EDIT3: I can make the Ordos rewards come back by buying some stuff from the Ordos vendors. My conclusion is the following: the system is messed up and needs fixing.

This post was edited 10 days ago by treecargarage
Store Page
Share
2 comments
Intel Ordo rep working properly?
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
5 days ago
+1
Posted by Marcopolocs 7 days ago
I'm pretty sure there is nothing wrong with the 33% chance but in any case we will look into this to confirm.
There is 100% something wrong with it.

Back when I was testing, not only was it not 33%, but doing different things, like...

1) alternating between user-created and game-created Intel missions

2) buying items from the stores

...altered the %.


Perhaps you guys have updated the game in the meantime, but I have given up on Intels after getting the required amount for buying sparks and mechanisms.

7 days ago
I'm pretty sure there is nothing wrong with the 33% chance but in any case we will look into this to confirm.