Graphics Settings

3

I've been playing for a few hours so far, and have been enjoying every minute of it.
No crashes to report and no bugs yet, but more of an observation.

Performance seems to be quite poor...I would say sub 20 frames per second, and the game seems to be stuck on the "Very Low" graphics option.
Changing my graphics settings seems to make no change to the overall appearance of the game, or indeed the performance.

Spec is quite modest:
2GB GTX 660 Superclocked (EVGA)
i5 3.4Ghz
16Gb DDR3 RAM

But would expect to be able to play on Medium settings at around 30 fps

Understand game optimisation isn't a priority at the moment, but if there is something I am missing regarding altering the settings it would be handy to know

Thanks!

Store Page
Share
3 comments
Graphics Settings
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
1 year 207 days ago
the extra lighting settings are making a difference in performance, also the game didnt really have any optimization, so even on a stronger build it has quite low framerates (i5-4690, 16gb ddr3/1833, gtx 970 OC here).W ith everything on maximum (1080p) i have ~35 average fps, of course there are people with stable 60 fps on any settings, but those are the ones with gtx 1070, 6th gen i7, etc. By the end of the beta, with that build you'll be able to have stable 60 fps on medium, i think even on high, considering how good the optimization was with Neocore's previous titles.
1 year 207 days ago
Puzzony
I appreciate your reply, thanks.


I managed to get the shortcut added to the Nvidia Control panel by deleting the Steam shortcut from the desktop, and placing the main .exe shortcut on the desktop instead. It then showed up within Nv control panel and allowed me to modify the settings from there directly.
Now looks much better and it seems to run a bit better too (but this could be my mind playing tricks on me)
Anyway, no real issue. Looking forward to what future updates bring us :)

1 year 206 days ago
Posted by RobotXander 1 year 207 days ago
I appreciate your reply, thanks.


I managed to get the shortcut added to the Nvidia Control panel by deleting the Steam shortcut from the desktop, and placing the main .exe shortcut on the desktop instead. It then showed up within Nv control panel and allowed me to modify the settings from there directly.
Now looks much better and it seems to run a bit better too (but this could be my mind playing tricks on me)
Anyway, no real issue. Looking forward to what future updates bring us :)

Tried this too - and I too were able to add the game to the NVIDIA control panel now... unfortunately it doesn't work, the game still lags if I just run it using steam (integrated graphics card) - Instead I right click my shortcut and pick my GPU from 'run with graphics processor' and get 40+ fps on low.