Game not using NVIDIA Graphics card

7

Hi,

I bought the game last night, but its pretty much unplayable right now. 

I have a MSI 72 /RE wíth an Nvidia 1050Ti graphics card. Even though it does say that it uses it in the nvidia control panel, the game feels incredibly sluggish, like 3d games do, when they use the onboard graphics card.

Is this a known issue? I have a hard time figuring out any kind of search in these fora.

Thanks!

Store Page
Share
7 comments
Game not using NVIDIA Graphics card
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
1 year 240 days ago

I believe this is a known issue, I have had it as well. The way to make it use the proper graphic card for now is to navigate to the folder where it's installed, right click on the game icon, choose  "Run with graphics processor", then choose your Nvidia card. You'll have to do this each time it's launched until that issue is addressed.

1 year 240 days ago

You can also set the game to use your card through the nvidia control panel. Right on the geforce experience icon in your task bar and open the control panel. You'll have to manually select the game then set it to use "high end nvdia processor" or something similar from the drop down. 

1 year 240 days ago
Posted by Daijodan 1 year 240 days ago

You can also set the game to use your card through the nvidia control panel. Right on the geforce experience icon in your task bar and open the control panel. You'll have to manually select the game then set it to use "high end nvdia processor" or something similar from the drop down. 

Hi,

I did try this as I tried to explain, but to no avail.


MORTISREX- Thanks, I will try this.


For now I got it to work by setting ALL usage to the NVIDIA card, but that just taxes it unnessarily in the long run.


Anyways - thanks for the replies, guys - See you on the battlefield!


/PS - I'd kill for a Warhammer Fantasy version of this  as well!

1 year 238 days ago

Hope they fix it for you, i've found the game to be very CPU dependent from my benchmarking thus far. Would imagine a 1050 might struggle a little while it's not optimised. Try running shadows and particle effects on their lowest, everything else doesn't seem to impact fps as much.

1 year 238 days ago
+2
Posted by razgon 1 year 240 days ago

Hi,

I did try this as I tried to explain, but to no avail.


MORTISREX- Thanks, I will try this.


For now I got it to work by setting ALL usage to the NVIDIA card, but that just taxes it unnessarily in the long run.


Anyways - thanks for the replies, guys - See you on the battlefield!


/PS - I'd kill for a Warhammer Fantasy version of this  as well!

Instead, put a shortcut to the .exe file on your desktop.

From there right click and choose 'run with graphics processor'

choose Nvidia Graphics Driver


So you don't have to have all run on your NVIDIA card :)

1 year 226 days ago
Posted by Airsick Hydra 1 year 238 days ago

Hope they fix it for you, i've found the game to be very CPU dependent from my benchmarking thus far. Would imagine a 1050 might struggle a little while it's not optimised. Try running shadows and particle effects on their lowest, everything else doesn't seem to impact fps as much.

I find the performance quite surprising. I'm getting the feeling the NVidia card isn't used by the game (GTX 765M, yeah, oldish but should still be able to run this kind of game with 0 issues) since I'm still geting 10-13 FPS even when I select the ´run with high performance Nvidia card´ option. I have a 2.7GHz I7 which, with four physical cores, should again be able to run a game like this without any problems. Yeah, I get that this game is in alpha, but there´ve been a TON of posts about this issue, and fact is that laptops are by far the dominant platform sales wise, so not actively fixing this issue makes them lose out on a LOT of potential testers and is also super frustrating for people who´d actually like to test / play the game instead of look at stuttering all day.

1 year 98 days ago

I'm running on a HP Omen 15-ax201np (i7-7700HQ, 16GB ram and a 1050ti) it runs in 1920x1080 with maximum graphics at 60fps (i've capped my nvidia settings to 60fps) without any issue.