FIX: D3DCOMPILER_47.dll is missing

14

Fix: Renaming D3COMPILER_46.dll to D3COMPILER_47.dll !

Also try this:

  • Exit the game.
  • Right click on the game in your Steam Library.
  • Select "Properties" in the dropdown.
  • In the window that pops up, select the "Local Files" tab.
  • Click the button on this tab labeled "Verify Integrity of Game Cache".
  • Allow the program to run, it may take up to five or ten minutes.
  • Once it is completed, close down your Steam Browser
  •  Exit Steam completely from the toolbar.
  • Restart Steam and see if it helps.
This post was modified 1 year 215 days ago by Valkyrie Neocore
Store Page
Share
14 comments
FIX: D3DCOMPILER_47.dll is missing
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
1 year 218 days ago
+1
Posted by Megapull 1 year 219 days ago
If you are using Win7, Installing Win8.1 SDK should help, too.
i've tried both of these fixes. none of them works for me. when i try starting the game the Steam load box appears for a millisec then dissapears and the game dont start up :/
1 year 219 days ago
+1
If you are using Win7, Installing Win8.1 SDK should help, too.
1 year 218 days ago

TY - it's help

1 year 218 days ago
This worked for me !
1 year 219 days ago

Edit: I missed your body text. Derp.

This comment was edited 1 year 219 days ago by SterlingThundercock
1 year 218 days ago

Didn't work for me...


EDIT: actually it did, thank you!

This comment was edited 1 year 218 days ago by christian dingkuhn
1 year 218 days ago
How do I do this?


1 year 218 days ago
Have downloaded SDK, uninstalled an reinstalling. Will c if it makes a difference.
1 year 218 days ago
Hello there. I agree with NOAIM, no one of two suggestions of "how to start the game" didt work for my win7. Just push Play button on steam, saw some screen in a moment and nothing. 
1 year 218 days ago
Fingercrust
Didnt know what, but something helped me to launch it..
1 year 216 days ago

I am having the same issue when I try to ru the game, click the start button on steam and nothing happens. After try everything noted below I just went to the warhammer_64_11.exe on the local folder and try to start the game directly from there but I am getting a system erro, d3dx11_43.dll missing. My directx11 is update, aswell as my graphic card drivers so I don't know what to do next, and I don't trust .dll download sites. Any suggestions?

1 year 217 days ago

Didnt worked for me.

I also tried reinstalling the game after cleaning the windows registry. It just keeps crashing on logging screen.


Operating System: Windows 10 Home 64-bit (10.0, Build 14393) (14393.rs1_release.161220-1747)
Processor: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz (8 CPUs), ~4.0GHz
Memory: 16384MB RAM
Card name: NVIDIA GeForce GTX 1070

This comment was edited 1 year 217 days ago by Kaskeria
1 year 217 days ago
Posted by Kaskeria 1 year 217 days ago

Didnt worked for me.

I also tried reinstalling the game after cleaning the windows registry. It just keeps crashing on logging screen.


Operating System: Windows 10 Home 64-bit (10.0, Build 14393) (14393.rs1_release.161220-1747)
Processor: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz (8 CPUs), ~4.0GHz
Memory: 16384MB RAM
Card name: NVIDIA GeForce GTX 1070

Well this is weird. Just posted this comment and tried again and the game worked. Dont know for how long. Ill keep updating on this matter
1 year 216 days ago
adria renau
Ok, I finally downloaded the missing file from a safe site, scanned a few times and copied the file into the game folder, and it worked!