Co-op server timing out


two friends and I were trying to play some co-op in warhammer inquisitor martyr, but we were unable to connect to one another. the hosts gets told that the server timed out, while the other two of us, are stuck in the connection screen, trying to reconnect to the non-existent server... we could only exit, pressing ALT+F4. - we tried changing hosts, and to play with fewer players (just to test things out) - but no succes

It works fine for all three of us, if you play single player. the problems is only there, if we try to connect to each other

Store Page
Co-op server timing out
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
7 years 37 days ago

I have the same problem. Tried to play some coop. During the connecting phase, the message switched to "reconnecting" and nothing else happens. After a while i get the "server timed out" message and my friend is stuck in the connection screen. We have found out that you can get your squad buddies out of that soft-lock if you (as a host) open up a new mission and cancel the ready check. But other than that, no coop seems to work for us at this point.

7 years 35 days ago
It should be fixed now, please post if the issue has been resolved. Thanks!
5 years 24 days ago

Same issue here. Lost two intel missions like that plus 2 regular ones in coop with a friend.

EDIT: Damn, necroed the thread by mistake.....

This comment was edited 5 years 24 days ago by Immolator
5 years 24 days ago
May we ask did you try Coop with a friend and got an error 'Server timed out'? We will check on the case and reset Multiplayer if necessary! Thanks for the report!