Blueprints not transferring to inventory from trader

2

Just paid 50k for a Artificer Mk III Personal Void Shield Blueprint and it disappears from the list but I get nothing, tried switching Character then logging but still no dice. I do have a red and white icon appearing over my inventory when I log in initially but it disappears after I switch view etc.

Bit annoyed as I'm only lvl 8 and that was more than half my cash lols; thought I was onto a winner ^^

Also while I'm at it there's a few bits where the text on stuff cuts out mid sentence as if its run out of space.

Store Page
Share
2 comments
Blueprints not transferring to inventory from trader
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
1 year 40 days ago
Zardoz4
I've had blueprints disappear several times now, too, on different characters.  The cost is paid, they disappear from the vendor, but don't appear in my inventory. 


I wonder if it's click rate related?  I was tending to buy all blueprints one immediately after another, without noticing that they weren't going across.


The crafter NPC is available.



1 year 41 days ago
Did you already get your Crafter NPC? If so you have to go to the purple crafting tab or you won't see your recipe.