[xbox] Psychic Retribution heroic deed

6

Before you ask, im aware of the issues people have had with this deed. Ive read online, lots of people have had problems with this deed going back to before release. Im posting this in support rather than bug reports because it WAS working for me until it stopped updating today. The deed asks you to complete 10 missions using only psyker powers (it actually says skills but obv means powers). I managed to get it up to 4 completions yesterday before bed by putting fire aura on my pyro staff bar and running through lower level random mission while activating flame aura and ONLY flame aura. I went to finish the deed today, and suddenly it isnt working.

I tried only using bio lightning, didnt work. I tried doing missions like assassinations and purges that dont require any object interactions, just to make sure i never even touched any button other than Y my flame aura button, didnt work. I tried staying away from missions with allies and not detonating any exploding stuff, just to make sure no enemies ever died from anything other than flame aura, didnt work.

I even tried equipping all damage protection and doing a datahunt mission without killing a single enemy and it still didnt raise my number.

I was hoping that they were being counted some where and the progress tracker just didnt update, as ive had deeds (and their achievements) pop before that the tracker said was a ways off, but with all these experiments ive done significantly more than 10 missions using only powers and its still stuck at 4 with no update.

Could someone check out my char and see whats going on here? Im reasonably sure im not doing anything wrong as flame aura worked fine yesterday. My gamer tag is DR BAMF PhD MMT the char is lucien helonas.

Store Page
Share
6 comments
[xbox] Psychic Retribution heroic deed
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
171 days ago
Stephsmithers

The Heroic Deed is supposed to count the missions properly. Are you sure you are using ONLY Psychic Powers? Anything else, whether it is reflect damage, dot can hinder the progress.

182 days ago
Yeah coming back to this thread 2 years later and we are still having an issue with this deed. IM trying to complete it now for the first time and i was so baffled as to why it wouldnt progress. Perhaps the deed could be changed? Marcopolocs? please? just a wee bitty :)
2 years 247 days ago
+1
Yea, im a bit obsessive when it comes to.... Well, everything really. I apologive if my language took a turn to exasperation, i love the depth of the character progression in martyr so i got very frustrated over time as that ability point eluded me.

On an only slightly related note, the psyker deed "walking the line" says "complete 50 without maxing the warp heat bar", but it only progresses if you complete a mission without going into the red portion of the bar at all. If you ever enter the most dire warp state ("unhinged" i think?) that mission is out for that deed. This is a pretty minor problem but it still a misleading description. Unless of course ive mis understood the nature of the bar and yellow is actually the max (with red being an overcharge or some such)

2 years 247 days ago
That's some very detailed experimenting you have done @DR BAMF PHD MMT‍ we will follow your suggestions to see what things affect the Heroic Deed. Thank you!
2 years 248 days ago
+1
Ok i just got the deed, so it does work but its definitly bugged. For one, switching weapons invalidates it. I had to run a bunch of extra missions because of a few mysterious failures, so it forced me to experiment. All the powers are fine to use but most are risky, one mission i didnt get credit for i think because an explosive barrel went off and killed an enemy. Another time i couldnt figure out what went wrong untill i realized the only difference between the previous mission is that i had walked away from an enemy and let it die from a burning DoT.... Which i inflicted with a PSYCHIC POWER. Another time i did a panic room and i saw an imperial guard kill an enemy, no credit. It seems to me that the only way to get credit for a mission in this deed is to ensure that absolutely every enemy dies from direct, personally inflicted spell damage. Even your own spell DoTs are unnacceptable! Which means that any mission with allies or hazards is immediately out, and the only practical way to get it is to run low level assasination or purge missions using only flame aura. Thats utterly absurd, and it cant possibly be meant to work this way. It should redesigned to only rule out progress when you use a weapon skill. Either that or change the description to "10 missions completed without switching weapons, hitting barrels or doing damage with anything but flame aura", at least then i wouldnt have had to experiment for hour figuring the damn thing out
2 years 248 days ago
This is very strange, it suddenly started working again. I did 2 assassination missions, not opening chest or interacting with anything except to put my flame aura on, and i got credit for them! The only thing i changed is to put my flame aura on my first weapon set so i wouldnt have to switch to my pyro bar at the start of every mission. Unless the server suddenly woke up and started counting my missions again, this dumb heroic deed is counting switching weapon sets as a "skill" that invalidates progress for it. If so, thats obviously a bug and needs to be changed