Voice audio stuttering

7

The audio sounds perfect EXCEPT for the voices while on a map -- the voices from my own character and also the voices from the enemies all stutter.  

I'm using headphones.  Soundcard: Sound Blaster Z.  Windows 7 x64.  16 Bit, 44100 Hz

The stuttering is very... peculiar.  It sounds AS IF the game can't decide which channel (left or right channel) to send the audio to, so it SEEMS like it rapidly switches between left and right (like 8 times per second) with a small silent gap (lost audio) in between.  Just for the voices.  Everything else is fine.  The issue is not intermittent -- it's 100% consistent, and it's kind ruining my enjoyment of the game.

I hope the way I described it makes sense to whoever reads this.  I can record it if that would help.

Note: The Sound Blaster Z in headphone mode is one of those cards that's a little weird.  Weird in that it normally wants windows to be setup as if you have a 5.1 speaker setup, and then the software (a windows service) translates that into positional stereo audio.  Anyways, I tried it both ways -- playback device>speakers as stereo (with that service disabled) and also as 5.1 -- it made no difference either way.

I have zero audio problems in other games.  I tried everything I could think of to fix this on my end, but there's nothing left to do but report it.


EDIT:

Here's the link to the video shared from my google drive that (with headphones) you will clearly hear the innapropriate reverb effect ONLY on the second voice (after I do the leap smash) :

https://drive.google.com/file/d/1uc_C5gFISyn2685-Yna8X5J-bu9wEXnm/view?usp=sharing

And here's the SAME audio for the above video of the issue DOWNMIXED TO MONO -- it sounds perfectly fine with headphones!  So I was right -- the game is screwing up (or this is mistakenly done intentionally?) deciding which channel to send the sound to for these events: 

https://drive.google.com/file/d/1_M1jTQoD7BIfv2EfU8MaUH7uBDuZAVXM/view?usp=sharing

EDIT2: As a workaround, I'm using a program called voicemeeter -- it allows me to downmix my stereo audio to mono just for this game.  Besides the obvious downside, this adds a small delay to all audio ingame.  It's preferable to the alternative, but FAR from ideal.  PLEASE fix this!  Just fix those FMOD voice events.  I know I'm not the only person experiencing this.

EDIT3: I found this recent stream on youtube where I can also hear this bug at 10:28, 10:43 (he recorded in stereo): https://www.youtube.com/watch?v=J0zwewYFwC8   Does EVERYONE get this bug? Yet no one is talking about this???

EDIT4: I believe EVERYONE experiences this bug but either a) not noticing so much because they're not using headphones; b) they are using headphones, but they're shitty headphones so everything just sounds like crap in general; or c) they're using headphones but with the 5.1 setup with the Surround post-processing cranked to 100 (which is basically more mono than stereo audio at that point).

Since this is simply the way the game sounds and the developers don't seem to care, I have to assume it's INTENTIONAL!  They INTENTIONALLY added a ridiculously strong reverb effect to the in-combat voices, completely ignoring the fact that MANY GAMERS use quality headphones.


This post was edited 202 days ago by Daemon Jax
Store Page
Share
7 comments
Voice audio stuttering
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
168 days ago
I have the same issue. It is especially prevalent on my Psyker when I enter Unhinged heat state. The voice that should say "So be it" and all character lines similar to that becomes extremely stuttered and almost disappears among other sounds. I have tried to set the volume of voices higher than game sounds and still nothing. I sounds like there is an active switching between the voice and other sound effects, like they are "competing" for audio time instead of being played simultaneously. 

I am using Realtek HD Audio Manager for my MSI motherboard, version 6.0.1.8619

176 days ago
Marcopolocs
Hi, I have the same sound card, and the same problem of character dialogue in-missions is garbled and stuttery. 

Is there any progress on a fix for this?

206 days ago
By the way, I opened the movie file I made in Audacity so I can inspect the stereo channels.   I downmixed both channels to mono, and it sounded perfect.  


This CONFIRMS that the game is screwing up determining which channel to play the sound on.  It's 100% not a DPC latency issue.
207 days ago
I'll also email the link to Mark, of course.
207 days ago
Marcopolocs

Here's the link to the video shared from my google drive:


https://drive.google.com/file/d/1uc_C5gFISyn2685-Yna8X5J-bu9wEXnm/view?usp=sharing


You can watch it and/or download it then watch it locally.  I made sure to capture the separate stereo tracks.  I used RTSS to show the fps and also the frame time graph (solid 60 fps with vsync, and flat frametime graph) in the upper left-hand corner.

This comment was edited 207 days ago by Daemon Jax
207 days ago
Marcopolocs
Sure thing.  I'll upload it to either dropbox or whatever and email Mark the link to the video, and also post it here.
207 days ago
Could you please record it and send the file to [email protected]? Our sound engineer wants to check it. 


Thanks in advance!:)