unable to craft


Hi since the beginning that i play i am unable to craft. When i try it does not consume ressources or money and just puts the craft in queue. Tried with different characters , tried validating files through steam , upgrading forge Nothing changes . 

Store Page
unable to craft
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
2 years 365 days ago

i'm not able to build anything since 2 weeks, i start crafting, timer runs down but when i try to claim the stuff, it just disappears, nothing ever is put into my inventory.

ACC: Kimble

2 years 365 days ago

I have no idea what you are doing at the moment, but although my techtree is OK and the Secondary Forge is researched indeed, my second Production Slot is missing.

On top of that I lost a purple armor that should have been crafted by now but is nowhere to be seen :-(

3 years 2 minutes ago

Thanks for the report guys, this'll be fixed within 1-2 hours, after you relog everything should be fine.

3 years 1 hour ago

I'm also have the same thing happen to me, it will consume credits and mats but will not build. I've treat with multiple characters and tried restarting with the item in the forge and also stopped it then logging out and restarting but still nope.

In-game: Charon

3 years 22 hours ago

if ever i managed to fix my bug by creating second production slot with tech tree it made both usable again :)

3 years 1 day ago


Pretty same thing for me, exept that it consume credits and materials. The item I want to craft appears in the craft queue but with no timer. An Exitus Rifle  (60 minutes to craft) is waiting since yesterday.

In-game account AlphariusOmegon.

3 years 1 day ago


3 years 1 day ago

I'm experiancing the same thing, does it have something to do with upgrading the Techtree? 

3 years 1 day ago
Hi, thanks for the report! Can I get an in-game account name?