Trying to load game -> Network error.


It gets up to the first screen, loads for maybe 10 seconds, then it says the network encountered an error.

Nothing I've tried in the past 30 minutes has fixed it.

This post was edited 3 years 1 day ago by ultramehreen
Store Page
Trying to load game -> Network error.
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
3 years 1 day ago

If you can't log in, do this:

  • Exit the game
  • Hit Win+R
  • Type in regedit and hit Enter
  • Navigate to HKEY_CURRENT_USER/SOFTWARE/NeocoreGames/Warhammer
  • Delete everything there
  • Restart the game
3 years 1 day ago
Thanks, we are looking into it ASAP - but bear in mind that it's the weekend so we may or may not have to wait a bit for the fix.
3 years 1 day ago
There is no update for the game pending in my system, though. It's fully downloaded as of an hour or so ago.

Each time I boot it up, it's just "network error." and reconnect does nothing.

3 years 1 day ago
An update was being released. Make sure to download it properly.