Support Not Responding

3

First and foremost, this is not a discussion thread. If you are not a member of the Neocore staff please refrain from posting here.

I wrote several emails regarding an issue I do not wish to discuss here openly to your suport team without getting even acknowedged that you did receive the mail in the first place. I dare say that's rather unusual buisness practice and, although those threads seem to have vanished, doesn't seem to be the first case. However, I want to solve this problem and get it out of the way as soon as possible. I'd appreciate if a moderator or a member of the support team could look into this matter. All personal data needed is stored in my profile and should be available to you. If you have any question feel free to post here or send me a pm. Thank you.

Store Page
Share
3 comments
Support Not Responding
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
1 year 210 days ago
Megapull

I'd like to thank you for your involvement and also mention that despite my initial doubt the issue could be resolved. It seems I was just not patient enough. Thanks to the Neocore support team as well, especially the one person who was dealing with my issue in a patient, helpful and understanding way - you know who you are.


I'm adding this here as positive feedback so that if anyone who might have concerns regarding support in the future, this may be helpful insight and reference.

1 year 212 days ago
+4


Your email was read and forwarded to the appropriate personnel right after it arrived. We receive quite a number of support letters, bug reports, etc. but we read every single one. Your topic needs another staff member's attention and it was forwarded to him where it will get answered.

This comment was edited 1 year 212 days ago by Megapull
1 year 213 days ago

Got a time frame for it?


If it was over the weekend, then don't expect a swift response.

If it was past ~5pm in the UKish, then don't expect a swift response.

It could also be a known issue in that thread if that's still around, and they're working on whatever this mysterious and urgent problem is.


AFAIK, they haven't set up an automated "we got your email" message yet either.

This comment was edited 1 year 213 days ago by KvotheTheArcane