[PS4/Xbox] Update for Inquisitor - Martyr | March 26

16

Updates for Martyr have been released. Please make sure that your console has downloaded the update fully. The game needs to be restarted for the changes to take effect.

v1.0.1.11 for Xbox | v02.02 for PS4 EU/US | v01.04 for PS4 JPN


New Features

  • Players can now display any clue's content with plain text for better readability (both in-game and in the journal)
  • Players can now reset all Option settings to default with a single button
  • The "Sell all" buttons at Vendors no longer sell consumable items
  • Plenty of new loading screens

Fixed Bugs

  • Various performance improvements
  • Various localization fixes for all languages
  • Fixed an issue where incorrect reward values were shown in the mission screen for Khorne missions
  • Fixed an issue where enemies' spawn animation was mispositioned during multiplayer "Defense" missions
  • Fixed an issue where online matchmaking was not cancelled after the party was disbanded
  • Fixed subtitle delays in the English intro video
  • Fixed an issue where an incorrect POI was selected in the Starmap when changing systems
  • The player's 'hold' actions (for example deactivating a turret in Silence the Guns missions) are no longer interrupted when a cover appears nearby while using "Advanced" layout and "Hold Cover" configuration
  • Players can no longer select "Kick Player" and "Delegate Leader" for themselves in multiplayer games
  • All Founder names are now correctly visible in the Credits, with every resolution
  • Fixed line break issues in the Japanese version which caused debug texts to appear in the descriptions

PS4 ONLY

  • In-game portrait videos are no longer causing massive performance drops
  • Players can now see their friends' in-game activity through the PS4 Friend list menu
  • Mission voting functions have been remapped to the touch pad: left side is Accept, right side is Decline
  • When accepting a game invitation while watching a cutscene, players are now correctly placed into a multiplayer session after the cutscene ends
  • Fixed an issue where it was possible to close the Account Linking window with the Options button
  • Network disconnection is now handled properly in the account linking process
  • The campaign intro video now plays more smoothly

XBOX ONE ONLY

  • Fixed the achievement requirement check algorithm to avoid unlocking problems caused by connection errors
  • After starting the game, the intro, developer and publisher videos no longer flash twice when skipped
  • Fixed flickering rock textures in various maps
  • Fixed an issue where the player could join a multiplayer game with another account that was invited
  • Fixed an issue where the third flashback video for "Chapter 3 - Revelations" was missing in the journal


This post was edited 31 days ago by Megapull
Store Page
Share
16 comments
[PS4/Xbox] Update for Inquisitor - Martyr | March 26
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
71 days ago
jackanape
Thanks for the report, we will check on the assignments! 
71 days ago
Posted by jackanape 72 days ago
Define a “random open world mission”? I go to the starmap and just pick any mission on any planet, using my max Puritan character, complete it but no ToughChoices achievement. Done this ten times now and nothing.


This is NOT fixed.

Also worth pointing out that Priority Assignments now seem to be broken too - tried running some with my back up character to max out their morality bar and I cannot get past the first choice screen of any assignment. When I press A to make a selection it just boots me to the sector screen and the assignment doesn't progress, if I select the assignment again the same three choices pop up and pressing A does the same thing. So I couldn't get any more morality score even if I wanted to. This is on Xbox One.


Can you fix assignments so that they work and give morality points every time or fix the Tough Choices achievement so that the game recognises that I've maxed out my Puritan bar. No point saying to just do an open world mission either - I have now done 10+ random missions on the star map and still no achievement. Has the algorithm stopped working again?> As I know the game has been having connection issue son the Xboe One for the last week so wondered if the two were linked. I do have the most recent update BTW.

72 days ago
Define a “random open world mission”? I go to the starmap and just pick any mission on any planet, using my max Puritan character, complete it but no ToughChoices achievement. Done this ten times now and nothing.


This is NOT fixed.

80 days ago
+1
Marcopolocs
Perfect now... Finally!!! Thank you very much
80 days ago
Hellraiser76
Please give it a try once again after seeing my reply. The achievement should pop up.
81 days ago
Already posted this on the official thread but just trying to make sure it gets looked at as soon as possible.. Playing on Xbox, user NMGCnewdawn, maxed out radical path. Did several random starmap missions, on several sectors, with several difficulties and the tough choices achievement (the last one missing) is still locked. Also, tried 3 priority assignments, no luck either. Tried a tarot mission, crashed. Please take a look. Thanks
83 days ago
NoPolitics

Please complete an Open World mission, the achievement will be unlocked after it ended!

@KLZEHR‍ we have been working on the performance on PS4 and several fixes have been made with the recently released patch as well. Further ones are to come with the next patches too!

83 days ago

Hello, still enjoying the game but was curious if you were aware of performance issues on the PS4?  I'm still seeing a lot of flickering rock textures as well as floors, walls and other pieces of the environment that flicker on the PS4. Also my Character sometimes looks blurry and framerate slows down during big battles. I'm playing on a base PS4 (not a pro). Thank you.


84 days ago
My character is fully puritan, tried running a random mission this afternoon on Xbox One and still nothing unlocked.  Is it a random assignment or a random mission, any particular systems?
84 days ago
+1
Marcopolocs

It worked this time!!


Thank you

84 days ago
+2
jaysin
Run a random mission with your Huma character which reached the end of the Radical path! You should get it this time!

@TRUKK‍ please also complete a random open world mission the trophy should unlock!

84 days ago
+2
Posted by Marcopolocs 85 days ago
Please log in and complete one random Open World mission regardless of its type. Confirm if the achievements popped up.
That worked. Thank you for being a good staff member and not censoring my post. Even tho I know a few was at boundaries


84 days ago
Marcopolocs
I have full Puritan, just ran a random mission on the star map and tough choices did not unlock.
85 days ago
I have the same issue with tough choices.  Ran a random world mission and it still didn’t unlock.
85 days ago
+1
BekkaToravu
Please log in and complete one random Open World mission regardless of its type. Confirm if the achievements popped up.
85 days ago

My last two Xbox Achievements still have not unlocked as per the many assurances of MARCOPOLOCS accross numerous poast promising an algorithm "in the next patch". This is the third patch in which coming back to the game in late November.

The steps I took BEFORE playing today was as follows. Unintalled ALL of WH40KIM data. Alternated my Xbox MAC address. Hard Power Cycle. Reinstalled all WH40KIM datat. Reset Console. Managed WH40KIM to check for updates. NONE. Initiated game. Pcked charracter. See below. Still no working algorithm 


Tough Choices: Reach the end of the Pritan or Radical axis of the moraliy chart.

I was max Radical and was lucky enough to have a priority assignment with a Puritan and Radical choice to hit max again. NO ACHIEVEMENT


All Kinds of Trouble: Complete at least one type of every mission from the star map.

On my Pskker I ran all 11 missions 2x using different colored dificulties and enemies except Nurggle Infestation which is a set enemy type. I the ran all 11 mission types on my AssAssin and Crusader. NO ACHIEVEMENT