Poor frame rate

4

Since the 2.0 update I have been getting frame rates in the single digits whereas before the game ran just fine. I have put all the setting to low and it has made no difference. Any ideas? 

Store Page
Share
4 comments
Poor frame rate
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
1 year 120 days ago
+1
Megapull

Yes I am playing on a laptop. Asus Strix found it was defaulting to crap intel video. Set launch to use Nvidia and everything is running great. Thanks for the help guys

1 year 124 days ago

I had to disable my on-board gpu on my desktop. Also made sure I wasn't in compatibility mode. Running it as administrator from a shortcut on my desktop. One of these did the trick for me.

1 year 124 days ago

If you play on a laptop like i do (Alienware with a 980m gpu), try going into your steamapps folder, right click on the 40k executable and run with your high performance gpu (if you have one). My issue was that the game was always defaulting to my internal gpu on the mobo and I got shit framerate. As soon as I forced the game to run with the Nvidia card, I was good to go.

1 year 125 days ago
Are you playing on a laptop?