Known issues & workarounds

583

Please take into consideration that these issues do not apply to everyone, and might be unconfirmed until further testing.

PLEASE REPORT NEW ISSUES IN OUR MANTIS BUG TRACKER

V0.1.5

  • Network error
    • It is due to the transfer of the dedicated server from 0.1.4 to 0.1.5. Should be fine after a few minutes automatically
  • Crash on Heroic Deeds
    • We might silent update this
  • Item disappear bug is being looked at at the moment - since 0.1.5 we have more info about lost items, and they are not erased which means we can give them back. However, our goal is to patch this globally instead of dealing with individual user's items, which should solve all such problems in the future. Stay tuned!

V0.1.4 

  • Items disappeared for 340 people during the weekend
    • They received 10K credits, inoculator and starting gear back on empty slots for compensation
  • Co-op issues

V0.1.3.

  • Muzzle flashes behind character sometimes

V0.1.2

  • Enemies occassionally getting stuck in the wall
  • Thunder Hammer allows you to jump out of the map
  • Issues with switching/equipping weapons
  • Jump Pack missing VFX and SFX
  • Rocket Pack missing SFX
  • Thunder Hammer hit SFX missing
  • Missile backpack not showing when it is charging
  • Unable to add the game to Nvidia control panel

Working as intended (For now. This is alpha guys, things can/will change):

  • Only level 1 systems available
    • Level 2 will be unlocked in the next content update. Bear in mind that your gear is what makes you more powerful, not your ingame level.
  • No inventory during missions 
    • You should set up your gear before missions so choose carefully!
  • Mission finished window popping up after being closed
    • You are in a queue. If there is a mission result that you did not get, you should get it in the next one.
  • Not being able to unequip items


------------------------------ Workaround section ------------------------------


If your game does not start, try this:

  • Exit the game.
  • Right click on the game in your Steam Library.
  • Select "Properties" in the dropdown.
  • In the window that pops up, select the "Local Files" tab.
  • Click the button on this tab labeled "Verify Integrity of Game Cache".
  • Allow the program to run, it may take up to five or ten minutes.
  • Once it is completed, close down your Steam Browser
  •  Exit Steam completely from the toolbar.
  • Restart Steam and see if it helps.
  • Sometimes you need to do this twice because mistakes can happen during the procedure.

Additionally:

  • Make sure that your OS has all necessary updates.
  • Check if your GPU drivers are up to date

If you get a missing WMVCORE dll error on startup, install this and this - it will help.

If you can't log in, do this:

  • Exit the game
  • Hit Win+R
  • Type in regedit and hit Enter
  • Navigate to HKEY_CURRENT_USER/SOFTWARE/NeocoreGames/Warhammer
  • Delete everything there
  • Restart the game

If you are forced to create a new account even though you have one:

  • If you are asked to create a new account upon starting the game, close and exit. 
  • Open up the properties dialogue for Martyr, and enter the following as a launch option: -login %u %p (where %u is your steam username and %p is your password).
  • Start up the game again, then when the account creation popup appears, type in your account name (as it appears in the Martyr Forums) and click create. 
  • You will retain your characters but it seems that your currency defaults back to 1000 credits and 50 fate.

Removing skills:

  • You can remove any skills in the skill tree, you simply go to the end and left click then right click on the spent skill point and it should refund. 

Level 5 fate bug temporary fix:



This post was modified 1 year 275 days ago by Morzan
Store Page
Share
583 comments
Known issues & workarounds
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
1 year 55 days ago

can anyone help me i cannot log in to inquisitor martyr ?? ive installed again verified game files tried console since this new update nothing works why cant i log in and play the game? thanks

1 year 224 days ago
+1

Possible workaround.


For those reporting the crafting bug. Where an item gets stuck telling you the craft is complete and doesnt let you retrieve it.


I have the same issue, or maybe similar. The game shows a finished item and cannot be retrieved, but in my case seems to be only a UI problem. The item was actually crafting but show complete. I waited like 30 minutes on items of 15-20 mins to be sure and then i can retrieve them.


Happened several times with different items. Always worked.

1 year 279 days ago

everything i exchange, either armor or weapon is gone at the next relog or starting a mission.

if i equip a bolter pistol and a shild the avatar will stop running, he will only skate arround and the weapon is gone when the mission starts.

i

1 year 279 days ago
found a small bug, Ultra wide screend the inventory does not work proparly and now I cant take out items out of my equipped slot
1 year 280 days ago
saon
I'm having the same issue. Has anyone been able to help you yet?
1 year 281 days ago
Game Don't start:


Hit play button on steam, a windows open briefly then close, and nothing more happen, game dont launch.

try Cache verification serveral time, and several re-instal.

Driver/Dx updated, seam nothing can solve my problemes.


1 year 282 days ago
This comment was deleted 1 year 282 days ago by Morzan
1 year 283 days ago
Blackscreen after i wanted to tab out of the game to windows (alt + tab). Had to restarted pc.
1 year 283 days ago
+2

Hi,


New bug found:


(Or I think this is just simply coded that way, but still needs a change)


When you approach any enemy or group of enemies, if you are out if sight or range, they will nott attack you.


Normally they will start to attack if you get in range or line of sight. (and it's happening also that way)


Issue: But if you are out of range and they still not start to attack you, but as soon you start to fire a weapon, an ability or throw a grenade, they start the attack. NOT as soon the attack hits them! No! They come towards you as soon as you press the button and the animation starts.

I think that should be changed.

1 year 283 days ago
+1
Posted by DrSion 1 year 284 days ago

equipping a powerhammer (onehanded) and equipping a bolter pistol at the same time causes the character to not have any animations. (attacks still deal damage), the character is just "hovering"

Same for any 'melee/pistol' setup I've seen so far. It locks the animation to whatever you were doing when you swapped to it, including cycling the run animation.

1 year 283 days ago
People - start using the Mantis Bug Tracker :)
1 year 284 days ago
Hello,

I was trying to upgrade my weapons but they keep vanishing once I'm in a mission and now I have hardly any credits and no weapons to fight with. I would equip but they are gone once I get into the mission. Restarted to no avail.

1 year 284 days ago
1920x1200 rez does not seem to work properly mainly noticeable in inventory screen as items don't line up with the slots/boxes properly (items seem to be in the box below the box they are in) will take screen shots later.
1 year 284 days ago
So got items back (Thanks for that was not to fussed about getting back) 

wargear is still resetting to old setups at start of missions tho sometimes items go back to inventory some time they just go.

1 year 284 days ago
+1

Greetings,

Find some bugs that you can find above: 

- No sound on purchases.

- Invisible enemies shooting from nowhere.

- Game start to freeze after defeating big enemy(dreadnought) Notice appears only on first fight.

- Turrets can't be picked up but when you navigate arrow on it, it show that this can be done.

- Unknown line appears after player run from "reborn plagueseer".

P.S. Sorry if all of this bugs was find.

Best regards,

Automatone.


This comment was edited 1 year 284 days ago by Automatone
1 year 284 days ago
+1
Logged in to an announcement that I had to accept pending rewards before I could launch a mission.  There is a small icon in the top left of the UI.  When I click on the icon, the game hangs.  I was able to reproduce this every time.  I jumped on another toon and I had a popup with actual gear that I could accept.  Not sure what the delta is between the toons but the issue persists on one of them. 
1 year 284 days ago

equipping a powerhammer (onehanded) and equipping a bolter pistol at the same time causes the character to not have any animations. (attacks still deal damage), the character is just "hovering"

1 year 284 days ago

choose your character -> pick up items -> change the weapon in the second slot -> go to Menu -> of all first slot disappears

so that the problem of the disappearance of objects is not solved ...

1 year 284 days ago

First I'd like to say thank you for all the work so far on this game. 


1st set of testing on newest patch V0.1.6. I did receive a lot of items when I logged into my  2 Assault Gunners. They have been the 2 to lose the most items. Went about configuring the load out for the first one and noticed the gear was not appearing on the character as it was being equipped. Showed him running around with no armor or guns in a pose like he was holding an invisible weapon. But the inventory screen said he was geared up so I thought visual bug. On to slay heretics. Loaded a mission and he was still no armor no weapons. All the action buttons were locked out except grenades. Aborted the mission and returned to inventory screen. All newly placed items were sucked into the warp again. Equipped new items. This time they showed up on the character and in the inventory. Restarted mission. Still no armor or weapons all action buttons locked except grenades. Aborted mission. Still had the items. Backing out to class select and back has no effect. Exiting the game altogether and relaunching resulted in all slots that had been changed to be emptied of items presumably to the warp as well. 


On to test 2nd Assault gunner and other classes.

1 year 284 days ago
V0.1.6 - just logged in and received lost items back as expected.


Started a mission (swamp map) and found both weapons missing, so had to quit out.  In inventory both weapon slots were empty, with weapons disappeared rather than moved to inventory.  Quit to desktop and reloaded but they did not appear on logging back in.  Bought replacements and started another mission (indoor map this time) and bug did not reoccur.

1 year 285 days ago
+1

Just tried out the Ground mission, Grav gun and Grenade launcher last night and here are my thoughts.


Ground missions:

- Unable to 'jump pack' from one part of the map to another if they are not connected due to Invisible wall syndrome

-- Suggestion: 

-- For immersion, make it so that we are able to jump through the invisible walls if the range would allow a jump.


Grav Gun:

- No sounds for the Grav Gun (link)

- Balance issue: The second ability of the Grav Gun is too powerful

-- Suggestion: 

-- Reduce the AOE by 50%, Reduce the damage by 25%, Reduce the slow by 10%

-- Second ability doesn't seem to affect buildings, like nests (link)


Grenade Launcher:

- The second ability seems to deal damage when it explodes, AOE, but not when the cluster grenades fall to the ground (link) may just be that I don't notice it though.

- Balance issue: In general, the Grenade Launcer is too powerful

-- Suggestion: 

-- Reload time should be increased or fire rate should be reduced drastically


1 year 285 days ago

I have had issues with equipping new weapons, I know Alpha phase.


Yesterday I equipped loot acquired bolter for my inquisitor and started new mission. Mission started and I'm equipped with default heavy bolter and plasma cannon. Today same character, equipped bolter and no weapon is equipped, now I like challenge but yeah.

Today, just now with new character, equipped meltagun and started mission, default plasma gun equipped.


Some visual effect weirdness also, didn't notice if there was info about this.

Skill tab shows 2 almost overlapping skill trees and I have to find the sweet spot when applying skill points.

1 year 285 days ago

Issue I just came across. You are able to equip a bolt pistol and close combat weapon combo, yet doing so halts all animations (walking/attacking/etc.) so it looks like your inquisitor is a levitating statue.

This comment was edited 1 year 285 days ago by Shadow0300
1 year 285 days ago
Rionnos
I think thats working as intended (I'm sure neocore will correct if I'm wrong :) ) as there is 3 imperium insignia on the mission progression bar one dissappears for each life lost, once all 3 are gone mission failed and vote to finish pops up.
1 year 285 days ago
Good Day, first off great game so far and huge fan of the previous titles. two bugs yesterday I played a mission got a new sword and flamer logged in today both gone no biggie game is an Alpha. 


Secondly not sure if it a bug or a feature :).....  but died three times during a mission and the game brought up the voting to finish option.  not sure if its the same as the surrender option voting,  but it wouldn't let me decline.  I accepted received partial rewards and that was fine but just letting you know. cheers guys keep up the good work.   
1 year 285 days ago
jaqdraco
strange thing. after buying a new armour, equiping it, i still appear "naked", and the system counts me as naked too from the damage i take 
1 year 285 days ago
yeah, item dissapearing again... this time my armour. i was checking out heroic deeds after allocating skill points, the game crashed after clicking heroic deeds and lost my armour on relog. 
1 year 285 days ago
Posted by Nurgling 1 year 285 days ago

I'm lvl 27 with attack power and lvl 31 with defense power and according to the mission text i'm losing credits, fate and experience and the higher lvl i get, the more i should lose.
I'm not realy losing them, its just, that the rewards say, that i get minus xp/fate and credits. 

This may be due to the fact we currently are only meant to have access to T1 gear and T1 missions. Any attack or defense rating above 1 will cause the fate, xp etc to lower for the mission rewards as (as far as i know) all missions are T1 at present.


Only work around i know for this is to use low ranking gear to run missions with.

1 year 285 days ago

I'm lvl 27 with attack power and lvl 31 with defense power and according to the mission text i'm losing credits, fate and experience and the higher lvl i get, the more i should lose.
I'm not realy losing them, its just, that the rewards say, that i get minus xp/fate and credits. 

This comment was edited 1 year 285 days ago by Nurgling
1 year 285 days ago
One thing I noticed yesterday with the mannable turrets:


After you hop into a turret to take controll, if you hoover your mouse in different directions, the barrel of the gun isn't rotating. JUst after you press fire.

(Maybe it''s already known, but wanted to make sure you take a note) :)

1 year 285 days ago
+1
Posted by Megapull 1 year 285 days ago

Item disappear bug is being looked at at the moment - since 0.1.5 we have more info about lost items, and they are not erased which means we can give them back. However, our goal is to patch this globally instead of dealing with individual user's items, which should solve all such problems in the future. Stay tuned!

Awesome! Good job guys!

I think I can speak in the name of the majority and say, just investigate and get rid of this issue in generell. Recovering every single item for every affected user would just take away too much valuable time from the main developement.


And since the progress will be reseted multiple times anyway during the alpha, there is no need to recover already lost items.

1 year 285 days ago
have also noticed that this item reset/loss can be triggered in the shop when sell old gear will come up with "invalid owner" or something like that and reset all the items you have changed if you have not sold them.
1 year 285 days ago
Megapull
Thats fantastic news think its the main bug that's getting to people so does that mean that one day we will login to a flood of items being returned to are inventories?
1 year 285 days ago
+2

Item disappear bug is being looked at at the moment - since 0.1.5 we have more info about lost items, and they are not erased which means we can give them back. However, our goal is to patch this globally instead of dealing with individual user's items, which should solve all such problems in the future. Stay tuned!

1 year 286 days ago
- Items still disappear when equipping  must re log in to stop this from occurring. 


- CO-OP - Getting a game is more stable however the latency issue is still unplayable any interaction with loot boxes, or actions such as reloading take up to 5 minutes, yes 5 minutes !  forces me to use plasma based weapons to avoid getting stuck with no ammo for 5 minutes , item pickups also take upwards of 5 minutes to register along with the activation of objective objects in missions like " silence the guns" 




 
1 year 286 days ago
Taeryn

after relogs or finished missions solded items is gone... but this screenshot It is the result of opening ~10-12 loot boxes.... 

1 year 286 days ago

So I had a random issue while playing today. On the outdoor map, I looked at my HUD map and found that there was a mob in front of me. However, they weren't visible in front of me. Move the mouse around and i find the mob under a rock. Turns out the model was not supposed to be there....as I found myself in the rock as well. 


Twas not a cozy rock. Twas a busy rock and hostile to boot.


Also, I just now noticed this, but on the Attributes page, it shows a different name and different character model, instead of my own. Has this been here for quite sometime, or  is this just a fluke?


As always, excellent work so far, and all of us are excited for what is to come!

1 year 286 days ago
Posted by lifefrag 1 year 286 days ago

it is impossible to sell the equipment when the available space is over in the store


Every time I go to a mission, complete it, and come back, my previously sold items are gone. Your items never disappear?
1 year 286 days ago
Just a thort I'm stall having gear reset and disappear and i know a lot of people are! Just wondered if all the people affected were also people that lost all their gear last weekend(like i did)?
1 year 286 days ago
Not sure if this is the place to report this, new to the alpha so finding out how things work. Had two instances of gear disappearing on log in over the last two days. Yesterday I played a couple of missions, equipped some drops into both weapon sets, logged out. This on my melee char. Logged back in a bit later to find all my weapons in both sets gone. Inventory ok, all progress ok. Today I played a mission with my assault char, all seemed good, logged out after changing loadout with drops and store purchases. Logged in an hour later, first set (autogun) weapon missing, second set (the heavy ranged) still there, all progress ok. Its a pain and I hope you can fix it soon but its not a gamebreaker:) I am loving this game at the moment, totally sold on all your ideas for the future, and look forward to helping to test them as best I can! Thank you for making the books and games of the WH40K universe come to life!
1 year 286 days ago

https://ibb.co/fWmgmF


https://ibb.co/jHqVfa


Attack power 12, 

Defence 16

Reward is negative.

I got critical errors.

1 year 286 days ago
I touched the video options and now the game is ok in the briefing room but when I go to choose my mission I get an overlay double image with one of them being partially set offscreen making the game totally unplayable . Have checked file integrity , have uninstalled and reinstalled.

 All drivers up to date. I'm using GTX1060 . Game worked fine until I tried to adjust some video options , now even if I set to very low I still get the dual image and I'm not even drunk !!

1 year 286 days ago
jollybest1
I had same missing gun issue , believe it was because I equipped two heavy weapons
1 year 286 days ago

1)Havoc in too fast missile attack speed, it is practically impossible to run away or dodge because they spam missiles

2)Havoks have homing missiles... and this is a problem

1 year 286 days ago
+1

it is impossible to sell the equipment when the available space is over in the store


1 year 286 days ago

i had some issues, but overall things are much better.


i loaded up this weekend to play and check out the new changes. i have been on my melee character for a few levels now so i loaded him up. i had the item loss bug somehow early on and my gear in my inventory only all became cleared. i kept what was equipped. i found the stash shortly thereafter, and decided to see if that place was safe (also hadn't attempted sharing yet). i got on my ranged character and grabbed a couple of guns from the stash. i decided to try out the grav weapon so i played a mission, maybe two on the ranged. when i came back to my melee character he had my old weapons replaced. they had been stored in stash so now i had a duplicate set of weapons. i just sold them and took it as balancing out lol. i played a chunk after that on the melee guy saturday morning. after not leveling too fast anymore, i decided to hop on the heavy at level 2. through all of this i had no more item issues.


i play at my house some, but i usually play at a lan center. after noon saturday, i left to head there. when i got there to play and show some of my friends the new patch, my melee character was taking up a slot, but he was not present. the model and character level were simply not there. the play button was grayed out. i could delete, but i could not play. i hopped on the other characters throughout the day, but in the evening i simply deleted my melee. he could not be accessed except to be deleted. i understand this is alpha, but that sucked, he was like level 9 with some cool rare gear. it's ok, i deleted him because i wanted to play on one, so i had started fresh. i haven't had this issue yet and i have been back and forth from my house and the lan center with no character issues. its now sunday morning and i'll let you guys know if there is anything else crazy.


issue summary (TLDR): i had the item loss glitch on the inventory only. storage unaffected. this only happened once since the last patch, upon first load (might have something to do with it). after playing and character switching, my melee character was stuck in limbo. the character screen showed that a character was preset in a slot, but the model was not there, play button was unclickable, and the level/type was not shown. didn't have to delete i guess, but i made a new melee anyway.


game is great so far! keep up the great work!

This comment was edited 1 year 286 days ago by Fenix12345
1 year 286 days ago
Level 5 bug temporary fix doesnt work by me :/ it still tells you cant play a mission until you accept your item reward  :/ ( item reward from Aethon system )
1 year 286 days ago
Posted by Zardorak 1 year 286 days ago
Maybe it can help you with the "dissapearing item bug" ... it only happened to me when i switched items by clicking.

Since i switched to drag and drop i haven't lost an Item (yet)

Doesn't help.

Tried it also with equipping weapons with rightclick, and also with drag-dropping.

But what I noticed, it happens less with items bought from the vendor.


Someone suggested that after equipping a weapon, you should log off and log on again. But I tried it and isn't helping.


1 year 286 days ago
Galandyr
Maybe it can help you with the "dissapearing item bug" ... it only happened to me when i switched items by clicking.

Since i switched to drag and drop i haven't lost an Item (yet)

1 year 286 days ago
Posted by Pheguth 1 year 287 days ago

- when a stationary cannon is destroyed while you mounted it you get stuck inside, after surrendering you still get a strange camera behaviour while on your ship

- random generated rocks on surface missions have no clipping

- weapons still disappearing in missions after weapon switching in inventory

I've also been experiencing the 2nd two of these occasionally. Also, the first time I died was to the stationary cannon bug. Oh well.