Mission's Reward Does Not Appear


After each mission I get a list of what I have collected and I can open a reward box. I also get experience points etc. This screen does not appear. Everything is delayed - when buying and selling items, you have to wait at least 60 seconds before this is possible.It's not my internet or router or Xbox console. My buddy has the same problem.

Store Page
Mission's Reward Does Not Appear
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
3 years 342 days ago
My wife and I just experienced this for the third time each just now. All the loot we collected during the mission is nowhere to be found and there was no reward screen. Super disappointing as we had both collected loot that we were excited about. This is supposed to be a loot-based game but loot is broken half the time.

I've only been playing this game for a few days but it seems absolutely riddled with bugs. Is it still early access?

3 years 343 days ago
Solved! Thx!
3 years 343 days ago
Thanks, the problem is solved :)
3 years 344 days ago

We made changes on our backend and it should be good once again! Please check on it!

3 years 344 days ago
I am having the same issue across all characters on my account.  At the end of each mission after selecting exit, it seems to hang for 10 to 30 seconds.  Sometimes I then get the standard mission reward screen and sometimes I just land on the Command Bridge.  In either case, there is no loot in my inventory, no XP or credit gain, and the mission has not advanced.  One time the mission appeared to advance to  2 of 8, but after I logged out and back in the mission was back to 0 of 8.
3 years 344 days ago

Same problem

Gt: OmegaKiller101x