Mantis Bug Tracker

82

Welcome to the NeocoreGames Bug Tracker!
 

NeocoreGames Bug Tracker: http://neocoregames.com/mantisbt/ 
(You have to create a new account for Mantis. After registration you will be able to report bugs there.)

You can report bugs you've found in Warhammer 40000: Inquisitor Martyr using this bug tracker tool. The bug tracker will be implemented into the game in the next update.

Before you report a bug , please perform a search first to see if someone has already contacted us about it to prevent duplicate reports being made.

 Tips for Making Awesome Reports: 

  • Submit ONE issue per report please, it's easier for us to follow and manage! 
  • Please provide a (to the point) summary of your problem. Avoid one worded summaries and things like "help!!!". 
  • The description should contain details of the problem and how to reproduce it, so that we can more easily track down the problem and try to fix it. 
  • Please search before creating a report to make sure your issue hasn't already been reported. If it has, please join the discussion there!

    Please take your time to read following instructions, so you can make it easier for us to identify and fix the reported issues.

 There are tons of different systems and different issues which will be caused by different things. Too much variables to guess right.

Before you do anything

 Can you reproduce the issue?

  • Check if the right game is selected in the top right corner. DO NOT report Warhammer bugs for Van Helsing and vice versa.
  • Try to reproduce your issue using a recent version of the software and an updated operating system.
  • Has someone else already reported the issue?
  • Use the search box  to see if your issue has already been discussed. 


How to report a bug properly

 Reporting an issue is fairly simple. However, the more information you give us, the better we’ll be able to help you to fix the problem. So, when you describe the issue, be precise - be clear.

  • Which operating system do you use?
  • Which kind of software/hardware have you installed? (This could be important in some cases.)
  • What steps will reproduce the problem?
  • What did you expect to happen? What happened instead?
  • Post screenshots if needed.
This post was modified 92 days ago by Megapull
82 comments
1 year 272 days ago
+7
Posted by SpirantFrame 1 year 272 days ago

||Crafting Bug|| :Win 7 x64 (up to date): Steam Current Content Build ID:168953D Patch 0.2.0


  • In summary the problem is not being able to claim (x) crafted item. Per Screenshot it shows a completed status, clicking the finish button does however send visible and audible ques of confirmation. 
  • I have recreated this problem 3 times in a row by starting the production queue with different items, and while in production logging off. 
    • If the time spent logged off goes past the completion of item, said item is irretrievable. 
    • If logged back in before allotted time is up, item is retrievable. 

+1

1 year 272 days ago
+4

||Crafting Bug|| :Win 7 x64 (up to date): Steam Current Content Build ID:168953D Patch 0.2.0


  • In summary the problem is not being able to claim (x) crafted item. Per Screenshot it shows a completed status, clicking the finish button does however send visible and audible ques of confirmation. 
  • I have recreated this problem 3 times in a row by starting the production queue with different items, and while in production logging off. 
    • If the time spent logged off goes past the completion of item, said item is irretrievable. 
    • If logged back in before allotted time is up, item is retrievable. 

This comment was moderated 1 year 270 days ago by Jim Fox
1 year 273 days ago
+2
rusty5551
Ehm, you buy a game in alpha phase. What have you expected? A full working game with all content and completly balanced?!

Before the patch it was just boring after few missions because there was no challenge. Enemys were too weak, selfheal (HP-regen) too high, dmg taken too low. Now it's hard at the beginning (for me I like it this way), especially playing melee with chainsword. For casual gamers it might be too hard and unbalanced, but its still alpha, so balancing should not be the main part of current development phase. Alpha should make the game work, trying to fix all the issues resulting in game crashes and such things. Balancing is a thing you can do with lots of players where lots of builds are played and you can compare them.


So far: awesome changes with recently update, let the purge begin again :)

1 year 245 days ago
+2

Every time I start a game, roughly 4 or 5 minutes into it the game freezes to the extent I have to actually turn the whole PC off and on again, no keyboard input or anything. It's a fun five minutes though...


AMD FX-9590 Eight Core 4.70 GHz

16GB RAM

NVIDIA GeFroce GTX1070

Windows 10

1 year 254 days ago
+2
Posted by SpirantFrame 1 year 272 days ago

||Crafting Bug|| :Win 7 x64 (up to date): Steam Current Content Build ID:168953D Patch 0.2.0


  • In summary the problem is not being able to claim (x) crafted item. Per Screenshot it shows a completed status, clicking the finish button does however send visible and audible ques of confirmation. 
  • I have recreated this problem 3 times in a row by starting the production queue with different items, and while in production logging off. 
    • If the time spent logged off goes past the completion of item, said item is irretrievable. 
    • If logged back in before allotted time is up, item is retrievable. 

I am having this same problem. Cannot receive the finished item and cannot start another. 

1 year 269 days ago
+2
I equipped the Inquisitor with a thunder hammer. He held it like a rifle and did not swing it. Also he no longer walked but floated around the room. The sound was correct like swinging of a hammer and he still did major damage. So not a performance bug, just an animation/visual bug. Quite funny actually.
1 year 173 days ago
+1

Hi, I changed out an inoculator with the inoculator setup NPC, I then played a small mission and noticed my inoculator had 69 charges but would'nt work. I completed the small mission and checked my inventory and noticed my inoculator was no longer in my inventory, I then talked to the same NPC and as soon as my character came in contact with her my game crashed to desktop with the standard windows message of Inquisitor Martyr has stopped working and closed down, I tried this 4 times with the same result, I then purchased a new inoculator and loaded it up and since then have been able to speak to the NPC without crashing.


Just a strange little issue I figured the developers should be made aware of :)

1 year 97 days ago
+1

We still are missing the glory rewards from last week and the Cabal directives did not reset either. we cannot progress further with our cabal und need more space for members quite urgent.

1 year 202 days ago
+1
Hatchetforce
Thank you for the report! Added to our bug list!
1 year 199 days ago
+1

Got Exitus Rifle duplicated somehow on my assassin. After the last mission in level 1 investigation, copy of a weapon from my first weapon slot appeared in my stash. No idea how to replicate the bug, though. It was not listed in rewards from the mission, and it's exactly the same as the rifle I've crafted before doing the mission. Possibly crafting-related, as it may have appeared when I claimed a result of a different crafting I was doing during the mission, haven't checked my inventory beforehand.

1 year 287 days ago
+1

If you have any questions, ask here or on PM me on discord. When I get home, I'll make a short video about this to make reporting easier.

1 year 286 days ago
+1

1: Right clicking items into empty slots seems to have a lot to do with disappearing items. Has happened to me more than once today. Equip, go to mission and have no weapons or gear in some slots. There is no particular place you teleport to that this occurs.

2: Grenades and Tarantula have a problem deploying even with full bars of health and energy.

3: Some times when the red stuff (Q) is low and ever thing else is full it does not fill up as fast as other times, it is fast at times and slow at others.

4: When no weapon is equipped in a slot and you continue the play through without one the character will skate when the no weapon is initialized to move faster.

5: Items that are returned for the loses can not be sold and if right clicked to do so they disappear. Also had a copletion chest disappear right clicking it to open it.

My system;

OS Windows Home 10
Monitor - ASUS VG248 1920x1080 144Hz
OS Hard Drive 1 - Samsung 128GB SSD
Gaming Hard Drive 2 - Seagate 2 TB SSHD
CPU - Intel i5-4670K 3.40GHz
CPU Cooler - Cooler Master Hyper 212 EVO (Twin Fans)
Motherboard - ASUS Z87-A
1 CD/DVD R/W Tray drive
Memory - Corsair Vengeance Pro 16GB 2x8GB DDR3 2400MHz
GPU - EVGA GeForce GTX 970 4GB FTW GAMING ACX 2.0+
PSU - Corsair CX750
Case - Cooler Master HAF XB EVO Lan Box:

Razor Death Adder mouse

Razor Black Widow Keyboard

1 year 270 days ago
+1


1920x1080 p on a 4k 55in monitor. Win 10 x64 i5-6600K CPU 3.50GHz 32 GB RAM GeForce GTX 980 Ti. 


Text in the bottom left of the image goes off screen. You can still scroll like normal, you just can't read the last sentence since the bottom of the text box is off screen. The image shows the text after I scrolled as far down as it will go.

This comment was moderated 1 year 270 days ago by Jim Fox
1 year 130 days ago
+1
BrotherLazarus

Sry i will in the future.

1 year 275 days ago
+1

Hello every one.

Can some one tell me is this correct link to Bug tracker http://old.neocoregames.com/mantisbt/view_all_bug_page.php ?

This comment was moderated 1 year 270 days ago by Jim Fox
1 year 286 days ago
+1
Nasmo
It has been added.
1 year 217 days ago
Morzan

I did this and after updating all my dirvers the game was actually running for a good twenty minutes before crashing, until the new update when I got five minutes out of it again last night :(

1 year 245 days ago
Hi guys! 


Can you send a detailed email to the support team with a dxdiag?

1 year 273 days ago
Can't use it. No confirmation email, so can't register.
1 year 206 days ago

2 issues 

1: My cpu is on 100% when playing the assasin hero seems like when i use the sniper rifle it causes major cpu usage

2: i got 2 screens when i swap screens during loading the game gets stuck.


operating system: Windows 8.1

Hardware : Cpu i5 6500 .32gh  970 GTX 16gb

Reproduce the problem: 1: when i started using the needler snipe rifle my computer cpu flew to 100% and even the graphic ingame started to frame (graphic issues) later on i removed the needler and used every other sniper rifle and same thing 100% cpu usage when no enemies around and i dont use the sniper my cpu is back to 30%


2) every time i swap to my second screen doing loading it happens.


1 year 257 days ago

This weeks bug. When fighting a Dreadnought I like to run him around the room (as probably everybody does). Some obstacles he can shoot through (both guns and grenades), while others he cannot. In both instances I cannot return fire through said obstacles. Not a deal breaker just an fyi. I'm still having a boatload of fun!

1 year 216 days ago

Crafting and store not upgrading to power level 2. Crafting is showing Power level 2 stats but giving Power level 1 when finished crafting and store still selling power level 1 items.

1 year 272 days ago
SpirantFrame
In addition this bug does lock up the crafting station, you have to create a new character to craft items. 
1 year 239 days ago

Crafting bug!

When you are crafting tings and hang out too long ,your crafting  will get stuck!!!!(can't get the ting out,click finish but nothing happen and you can't craft new things)

1 year 239 days ago
Posted by SpirantFrame 1 year 272 days ago
In addition this bug does lock up the crafting station, you have to create a new character to craft items. 

Actually this is incorrect. I have made another character and crafting is still locked up with the same exact item. It would seem all credits and fate are transfered to all characters on the account as well as crafting items.

1 year 172 days ago

Hi,  Was Crafting a item then would out I had made the wrong one, cos it was in a queue I just cancelled the queue task I started by losing the matt's I use to make that item, but then I thought that ok still have matt's left go back to start over and now 90% of my crafting matt's are gone


dont know if you know about this :)

1 year 272 days ago
This comment was deleted 1 year 272 days ago by Jim Fox
1 year 172 days ago
HoorTael

I have also had this but it happened during combat. Wasn't able to do anything but move so got myself killed  to be able to continue playing.

1 year 97 days ago

Store on Command Bridge is unusable


I can access the Rogue Trader (Store) by simply clicking it, as should be.

In the store however when I mouse over an item in my inventory it shows the item description for a split second only before it vanishes.

I can sell items immediately after completing a mission, but not after starting the game or when I talked to one of the other bridge merchants.

On the store inventory side the whole item vanishes without a description popping up.

Needless to say: I can't buy anything there. When you click on empty air you get empty air...


Reproducable:

Absolutely.


Other reports:

None found, friend of mine has no problems.


OS: Win10 64bit

Software/Hardware:

CPU: Intel i7-6700K

RAM: 16GB (DDR5)

GPU: nVidia GTX780 Ti / Driver 385.41

1 year 97 days ago

Update:

Tried around some more and found that it's connected to the Reset-Timer.

Once that one reaches 0:00 it flips to "Resets in -:- - " and I can't buy anything new in the store.

1 year 234 days ago
Verusius

I to am experiencing the crafting bug. First couple times were successful but then an item got stuck. It says its finished but the item is irretrievable. The game is crashing a lot less this week.

1 year 234 days ago
Posted by Edinazzu 1 year 234 days ago

I to am experiencing the crafting bug. First couple times were successful but then an item got stuck. It says its finished but the item is irretrievable. The game is crashing a lot less this week.

Aye that's the exact problem I have though I've never had any crashes. Lucky I guess.

1 year 97 days ago
Dead God

That's most likely a balance issue.

I had a similar mission and as soon as you kill  the first assassination target the bonus goes down to +40%.

Until then it's damn hard, especially when you trigger another set of enemies.

But it makes a victory much more rewarding, imo.

1 year 233 days ago
Posted by Edinazzu 1 year 234 days ago

I to am experiencing the crafting bug. First couple times were successful but then an item got stuck. It says its finished but the item is irretrievable. The game is crashing a lot less this week.

I also have this bug

1 year 202 days ago

My friend gets black screened if hes in a menu when i start a mission up that last the entire mission.

Gas chamber doors delay opening when destroyed so the room remains filled with gas that may kill multiple times before it opens. and sometimes rapidly regen while being destroyed.

Sniper shot doesnt charge when used on world bearer decimator boss it only fires immediately even if you hold down key like you would for any other enemy.


Specs

AMD 8350 4.0

16 gb ddr 3 ram

970 gtx

Windows 7 sp 1 

This comment was edited 1 year 202 days ago by Amondus
1 year 202 days ago

Anti-Aliasing not functioning at all. This bug is repeatable 100% of the time on any resolution and with any advanced graphical settings. This includes 2x, 4x and 8x.

1 year 280 days ago

Anyone else getting a 404 error from the Bug Tracker?


Trying to report a missing character issue...

1 year 187 days ago

Hi, i was playing in a team yesterday, and after trying to resurrect (and not completly doing it) a team member i wasnt able to fire or use any of my weapon or armor skills, but i still was able to move, change weapons and heal my self. This situation persisted untill the end of the mission. 

This comment was edited 1 year 187 days ago by HoorTael
1 year 104 days ago

My Sniper Rifle stopped consuming ammo. The bug started after I had been playing co-op (my friend was party leader) and lasted for several missions. It stopped when I restarted the game.

1 year 280 days ago
Sharpe
Fixed.


Thanks for your feedback Sharpe!

1 year 168 days ago

Crafting don't work for me. Everytime i want to claim the Equipment it just disappears.

1 year 102 days ago

Since the update the textures of my inqusitor look like and unpainted tabletop model , some parts dark and some parts are grey the only thing that has color is the face and the weapons. Also if i equip a melee weapon and a range weapon at the same time my char holds the rangeweapon very wierd in his hand and not by the grip.

edit: also at one uncertain point midway trough the level it begins to stutter and the animations of weapons and deathanimations of enemies stuttering like hell even with the sync option on/off.

try reinstall the game hope it will fix it.

This comment was edited 1 year 102 days ago by Dead God
1 year 102 days ago
Dead God

I reinstalled it and now the details of the armor are gold and metal and not just dark gray blobs and i saw in a vid that the white armor coloring seams to be normal. 


I dont know if it is intended but the fullauto on the autorifle doesnt use any ammunition nor does the holografic weapon interface or watherver it is called , the thing with the CRIT-buff.

This comment was edited 1 year 102 days ago by Dead God
1 year 182 days ago

Hi, I have noticed when shooting from cover, the character's shots will hit the cover in front of me or the cover next to me, and not the enemies. I have noticed this most frequently when shooting at an angle from behind pipes. If I shoot at enemies from an angle, the shots hit the piece of pipe further down or the piece I am currently seeking cover behind, and not the enemies. It happens less frequently with other types of cover, but still occurs occasionally. Not a huge deal but does make the cover system more frustrating to use.

1 year 198 days ago

After crafting armor (the only item I've had the issue with), and returning from a mission with it equipped a duplicate will appear in the inventory.  Both in inventory and in the worn slot.  If the one from the inventory is sold they other will remain, but as soon as you enter a mission the worn piece disappears and you is naked.  Ending the mission and returning and it is still gone.  


Again I've only had the issue with armor and it happens every time across multiple characters.   If the duplicated armor  is left in the inventory both sets remain and have done so for multiple  missions.  

1 year 197 days ago

I just built a new system and upgraded everything except my graphics card. Once the OS was reloaded and all of my drivers, I loaded Steam and all of my Warhammer titles. When I jumped into IM, suddenly all of my higher resolutions are missing. The max res I can choose is 1920 x 1440. Any idea why the higher resolutions that were available before are now missing? 


EDIT: I restarted the game to no effect. Then I came here and made the above post. When I went back to the game and started it a 3rd time, suddenly the higher resolutions are now available in the drop down menu.

This comment was edited 1 year 197 days ago by Hatchetforce
1 year 130 days ago
Amondus

You have very similar hardware to mine , at wich grafical settings do you play , and whats the fps , i run everthing on medium , shadows off and only get 28 fps in big fights.

1 year 130 days ago

In the character screen the model of the weapon doesnt change , only if i switch to the second set and back.


FX-8350

MSI Gaming 1070 Gtx 8Gb

16Gb ram

Win 7 sp1

500 GB SSD


This comment was edited 1 year 130 days ago by Dead God
1 year 102 days ago

Few crash to desktops ylast night when attempoting to sort the Cabal list.

1 year 163 days ago

hi i am unable to craft since begining tried with different characters , it always puts the items in queue without creating the objects