heroic Deeds and directives are not progressing


Tried to do the "Complete 7 mission directive" to see if it's only a visual bug and it actually tracks it if you complete the 7 missions, but upon doing so, didn't get it completed. Same problem exists with the other directives, and with the heroic deeds as well. For a while, some of them worked (for example, got 76/250 nurgle creature kills counted), but not anymore.

This post was edited 7 years 121 days ago by Puzzony
Store Page
heroic Deeds and directives are not progressing
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
7 years 119 days ago
Heroic deeds sometimes track progress then seem to reset at random times, although I do not know what could have caused this.

 I managed to complete the 250 Nurgle creature kills yesterday just fine, so it is possible that it was fixed by the time I completed it, or it could be that issue may only relate to certain directives or it could be some other issue like only counting kills in a single mission. (The mission I completed the directive in happened to be one with many Nurgle creatures)
7 years 120 days ago
We are aware of this issue, and we'll fix it ASAP.
7 years 121 days ago
I havent had deeds working for me from the start. directives have stopped working for me too after Fridays patch