Gliding/No animation to moving when switching weapons

4

I currently have the Bolt and Grav gun equipped but when I started the mission my grav gun is now missing and when I switched to it (didnt realize it was missing) my character no longer has any animations. When I switched back to the bolter I still have no animations or gun sounds even though I have the visual effects and am obviously doing damage. 

Store Page
Share
4 comments
Gliding/No animation to moving when switching weapons
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
1 year 269 days ago
Animation is set by the weapon you have equipped so if you have none equipped the animation ceases to exist. However, the item loss is another issue. Did you lose your item upon starting your mission?
1 year 269 days ago

If i understand the OP correctly I think for EG he means when using shield slam while moving the character appears to slide instead of walk while the animation is going off, might be better to hold the character in place thorugh the cycle of the animation instead. Looks a bit weird. 

1 year 268 days ago
Megapull

Yes I lost the item on starting the mission, but when I switched back to my actual Bolt gun that did not disappear my animations were still froze as if I had no weapon equipped and there were no gun sounds being made from my character.  To fix my animation issue I just had to quit the mission I was on and re equip something on my empty loadout. 

1 year 267 days ago
Megapull

I have that gliding/no animation issue, when I equip sword and pistol. My char holds the pistol in a very strange way and doesn't walk anymore, but just glides around. I really want to go pistol/sword. It would be awesome if you guys could fix that sometime :)