Chapter 2: Saving Caius Thorn - Bugged.


Currently at chapter 2: Saving Caius Thorn quest, and at 4/5 clues found. When I click the next mission button nothing happens.

Think I completed the last quest - for the 5th clue - but it didnt register ---- This is my guess

Any help is appreciated =)

Edit: Forgot to mention; Did the quests co-op, dont know if that bugged it out or?

This post was edited 6 years 152 days ago by Name of Names
Store Page
Chapter 2: Saving Caius Thorn - Bugged.
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
6 years 150 days ago
Having same problem. Also did the Quest Co-Op
6 years 150 days ago

I did it solo, no may be the problem.

6 years 148 days ago
Same Issue Please fix !! since we are stuck with max LVL5 chars if the Story cannot continue because of this retarded bug.
6 years 148 days ago

Coop might be the issue, we'll look into it. Screenshots of the mission screen would be much appreciated - also, please post your account names!

This comment was edited 6 years 148 days ago by Megapull
6 years 147 days ago

Account name: Name of Names


This comment was edited 6 years 147 days ago by Name of Names
6 years 147 days ago
Name of Names

Double post.

This comment was edited 6 years 147 days ago by Name of Names
6 years 147 days ago
Happened to me tonight, played Co-op. Next mission button (at 4/5 clues) not doing anything and no way of seeing what stage I am up to.

Left group and reset the game, still not working. Seems going co-op has locked me out of completing quest.

6 years 138 days ago
I've had the same thing happen and I did everything in single player.
4 years 127 days ago
I completed the first mission in cooperation, the game stuck on the cutscene and booted us without credit, loaded single player today to try to finish it, but only the other two missions are available, and no credit for the missing one.  

Account Teatru

Character Aeleth

Xbox one

4 years 127 days ago
Hello, I've encountered a similar issue. I'm on Chapter 2, Saving Caius Thorn quest. I'm unable to travel to different systems to continue the quest. 

Didn't start the quest in co-op. However, upon starting chapter 2, I joined a co-op game with a friend. Playing an assassin character.

Playing on xbox one.

Account: JJM494

Character: Jana

Please let me know if you need any additional information.

Any help is appreciated.

4 years 126 days ago
@JJM494@TEATRU‍ please check on the issue again. They should be fixed now. 
4 years 34 days ago
This is still happening. It just happened to my character today while playing coop. 

Xbox One

Account: BasicGirl09

Character : Nikita

4 years 33 days ago
It's happening to my character too please fix this bug 
3 years 358 days ago
My game is also bugged says I only have 4/5 clues and won't let me progress in the story 


Inquisitor xxARCxANGELx

3 years 347 days ago

This recently happened to me as well, Co-op and everything. Now my character is locked.

Platform: PC

Character: Rita/ Assassin 

Name: Vulkan He'stan 

Build: 2.3.0

Thank you!

3 years 346 days ago
I have the exact same issue. I was playing solo. 

Happened 3 days ago. Tried to report bug on the in-game bug report option but it took me to the old site and I have had no reply. Can someone please assist. I haven't been able to continue playing now for 3 days.

I am playing on PC, Version 2.3.0c and I bought the game through Steam.

Please help.

3 years 345 days ago

I have the same problem, my character has no story missions in chapter 2. Name: Tugeim
Class: Crossover

I would appreciate it if you can fix it soon.

3 years 344 days ago
@MKETES82@ROBERTPAULSON707‍ we fixed the character problems, please check your respective chars.

@LOPPIE73‍ please let me know your account name and the platform you are playing on. Thanks in advance!

3 years 314 days ago

I'm having the same problem and have tried everything. Anyway you can fix it on your end? 

Psn maxichist 

3 years 314 days ago
having same problem, thought if i left it for a while it might get fixed in a patch or something.  playing on xbox one,  Rotheric Sins, character Alyria. 
3 years 313 days ago
We fixed your respective accounts please check your characters.
3 years 313 days ago
I think it's fixed now thank you so much. Really enjoy the gamr
3 years 238 days ago
I am playing on PC, did the quest coop and now I'm stuck on it. Can't see it solo or coop.  even cleared the whole system.  Pls help and thank you.
3 years 237 days ago
We resolved the problem please check on the mission when you will have some time.
3 years 233 days ago
I'm with the same issue on PC, can you pls help me?

PC: Neokronnus

3 years 232 days ago
Please check on your character now. We resolved the issue.
3 years 158 days ago

I'm having this bug on my crusader.

This comment was edited 3 years 158 days ago by ArtemisMoonfall
3 years 155 days ago
Please check on your Crusader, the issue got removed from him.
3 years 97 days ago

I'm having this bug on my crusader it is on ps4

3 years 97 days ago

I'm having this bug on my crusader it is on ps4

3 years 96 days ago
We fixed the issue, please check on your character's progress when you've got some time. 
3 years 96 days ago
This comment was deleted 3 years 95 days ago by Marcopolocs
3 years 45 days ago
Im having this same problem, please help!
3 years 10 days ago
Having the same problem locked out on 4/5 Chapter 2 saving Caius Thorn.

Please help me out here. This bug is present already 3 years.... 

My psn ID:


Heavy gunner crusader : sunradiance

3 years 8 days ago
Please check your character's progress, it should be good now.
1 year 201 days ago
Hello I am having this issue

Was playing Co-op and the quest updated for everyone but me

Playing on PC through steam
Steam ID Dominus Fabarum 

In game MasterLegume

Character name Hit Me Harder

It is a Heavy Gunner Crusader

1 year 201 days ago
This comment was deleted 1 year 200 days ago by Marcopolocs
1 year 200 days ago
The problem in question has been just fixed. Please check on your character.
1 year 114 days ago
I'm having the same bug with crusader on PS5

Username is Death-Blossom17

1 year 57 days ago
Still after all theses years this bug is till their no progress on the martyr chapter:2 saving caius thorn. No progress on the bar. 

Xbox series x Gamertag: Dredgen Gray