can't even log in to the game on steam

11

Can't log in through steam there is a blink of a screen with text: ..game is running... but nothing happens... i tried reinstall the game but again nothing happens..   good delivery Neocore...

Store Page
Share
11 comments
can't even log in to the game on steam
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
1 year 136 days ago
+1
Morzan
Support did great Work, quick response and the Problem was solved. thx
1 year 137 days ago
OGSteveB

Then please write a detailed email (ticket) to the support team - [email protected] They might ask some information like you location for e.g. They will help you fix the issue. 

This comment was edited 1 year 137 days ago by Morzan
1 year 137 days ago
Ogopogo
didn´t work for me
1 year 137 days ago
still cannot log in too

all other steam games run fine but martyr

it´s not the firewall, already shut her off

i also re-installed the game with no result

i also cleared the reg keys

give me a solution or my money back please

1 year 137 days ago

Possible solutions for connection errors (most likely will only work outside of Russia):

1. Try creating a new Windows admin user and try to login to the game. Sometimes admin account credentials get screwed up and this messes up games.

2. Delete the game's reg keys at HKEY_CURRENT_USER\Software\NeoCore Games\Warhammer Martyr\

3. Open an admin cmd, type netsh winsock reset and hit Enter

4. while there, type ipconfig /release (your net will go away) and then ipconfig /renew (it will come back), then ipconfig /flushdns

5. Disable proxies. Press Win + R keys. Type “inetcpl.cpl” and hit Enter.In Internet Properties, select Connections tab. Select Never dial a connection if you see it (somewhere below “Choose Settings if you need…”). Then click on LAN settings. Uncheck Use a proxy server for your LAN. If it is already unchecked, select Automatically detect settings.Click on OK all the way out.

6. Restore your default hosts file. (original looks like this: https://pastebin.com/eHc72maa)

1 year 137 days ago

Up, same problem here

1 year 138 days ago
-1
Check your .net Framework version.  I had a similar issue.  Once I upgraded to .net 4.7.2 I was able to launch
1 year 138 days ago
Morzan
LOL
1 year 138 days ago
+2

Due to the unexpectedly high amount players, our backend system may experience some delay or issues in the following hours. We are working on increased capacity and performance as we speak.

1 year 138 days ago

this halped 


I had the same problem, and I have, I believe, solved it.

1) I tried running the game through the "warhammer_x64_11.exe" in the game's folder - that gave me the error message, that the file "d3dcompiler_47.dll" is missing.

2) That same folder has a file "d3dcompiler_46.dll" - so, I copied that one and renamed to the required "d3dcompiler_47.dll", and placed it into the game's folder.

1 year 138 days ago
I just had the game turn black with the cursor still visible when entering a missing,

had to restart the game ...connecting,  no connect, no info. -.-


Also, That moving flame pillar from psyker did not despawn after 20 seconds when I used it, it actually did not despawn at all!
Now I just hope the probably related bug that made the crusaders turrets not-despawn forever is not still there,
otherwise it would be STILL IMPOSSIBLE to use more than 3-5 turrets in a mission until you have 3 permanent turrets and you can not cast any new ones due to bad game logic design wtf. ;-;