Bugs and issues PS4

2

This is equal parts bug reports and feedback.
Most of this has probably already been reported, but just in case:

Neocore account creation in game:

Nothing major, but still, should be looked at and form should be corrected as needed (either range of characters accepted, or state what characters are allowed correctly)

-Form for account creation states that Nick can be formed by Letters, Numbers and "Space"; It does not accept spaces in Nick.

-Password does not admit special characters ($, %, &...). When tried to create password with special characters (as anyone should in 2018...) the error message states that password must contain at least one letter and one number.

-Unsure if it was just a 1 time hiccup, or an actual issue with the in game account creation, but did not receive the account activation email until I tried to login here with a web browser and used the option to re-send it.

In game issues:

Auto-targeting:

-Targeting enemies in the far back, out of weapon range, making character run through all the other enemies that were charging at you, probably with your hand raised hoping to hi-five them all as you go. It doesn't go as planned.
-Targeting a mine that is within range but terrain geography prevents shots from actually detonating the mine, resulting in compulsively shooting at the floor, all while enemies try to knock you out of your obviously retarded state... with chainswords.
-Melee weapon attacks auto targeting explosives, which results on character running happily to explosive barrel and bashing it up close and personal to see the fireworks in all detail. So festive. Yay.
-Nearby cover, supply crates or just supplies being "targeted" before usable objects. No other alternative than breaking/opening/picking up all offending entities so you can interact with quest required objects. Tried moving out of range of cover/supplies before interacting with quest object, but as soon as cover/supplies enter range, character changes targets and ignores quest object.

Suggestion: Have a 3 options toggle:
1: Auto-target moving as necessary to position target in range.
2: Auto-target but don't move from the current position, attacking at walls (if there's a wall in the way) or just at the air (if target is out of range).
3: No auto-target.

Suggestion: What about keyboard and mouse support?

Suggestion: Controller layout just like current Advanced, which changes the attack buttons so L1 and L2 correspond to Left hand weapon attack 1 and attack 2, and R1 and R2 correspond to Right hand weapon attack 1 and attack 2.

Quest end bug:

-In some occasions, upon finishing the quest and pressing touchpad to end the quest and return to base, after fade to black the screen shows the quest area again (same position it was when touchpad was pressed and quest "ended") and stays like that. Character is gone, but game doesn't move on to base. Only way to go back to base is exiting the mission via options menu, which results in quest incomplete so no progress or rewards.

For reference, in case it's relevant, it was a quest in Charkov, one of the "disable the AA towers" missions, without bunker bombing.

Quest difficulty bug:

-Option to select quest power rating is not available (as in doesn't show at all) in any mission not part of the main story quests.

Local Coop:

-Only pregenerated characters for the cooperator? Really? I get the feeling the cooperator would be much happier if he/she could pick their own character that they have been playing in single player for cooperation, keep upgrading equipement and stats, etc. I know my wife and I would... that's what we bought the game for in the first place.

Store Page
Share
2 comments
Bugs and issues PS4
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
2 years 62 days ago
Thanks for all the feedback, really useful! A targeting priority system is already in the works.
2 years 62 days ago
Thats not all (PS4):
  • Laggy gameplay, even with only few enemies on screen, with more enemies the game becomes slow as hell (multiplayer is nearly unplayable)
  • Screen tearing the whole time, while moving around (at least on my TV on 1080/1440p)
  • Insufficent instruction/description on many of the symbols/buffs and debuffs on inventory, map and enemies
  • Uncountable translation faults (at least on German) on every text, mostly grammatic faults

And the rest that have already been mentioned.

But I have to say, I have fun the whole time - even when the game is nearly unplayable.