A few new bugs

1

Hi guys

First off, a massive thank you to you guys at Neocore for continuing to make Martyr one of the best 40k games out there! Great job, really enjoying it!

A few bugs have crept in though:

1. Aethon System - The new Rebel Guard mission there causes a crash everytime I tried to start it, black screen and had to use task manager to close the game.

2. The melee weapons are now held correctly in the Inventory screen but my Plasma Pistol is now being held by the top rather than the handle.

3. The Character and account levels and xp boxes are still misaligned on the Character screen making them hard to see.

4. My new PL1 guy still crafts PL4 stuff rather than stuff for his own PL. It displays PL1 numbers when I start the craft but I get PL4 numbers at the end.

5. A few of the new Heroic Deeds don't appear to be working:

Traditionalist - not going up

Relentless - not going up

Relic Hunter - This is going up every mission, not just the Hunter missions.

Battering Ram - not going up

Purifying Flames - still not working


Keep up the great work, looking forward to Executions and Massacre bonuses soon :)

Store Page
Share
1 comments
A few new bugs
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
1 year 99 days ago

Traditionalist works


Relentless works


Relic hunter worked - except it completed WAY before i had done 100 missions of that type, i can safely say i had done maybe 25-50 missions like that but no way had i done 100 yet.


Battering ram works


Purifying flames still does not work