Storm Shield - Shield Charge doesn't always work

6

Hey guys, I've been finding that the Shield Charge ability on the Storm Shield sometimes doesn't work, instead of charging I just get the animation colours around my character but no charge or damage to enemies.

I'd also like to add that when the skill does work, that although it does a ton of damage, the animation and sound effect don't feel impactful at all which is a bit of a shame for what would be a really cool skill. The sound effect is just a fizzle and it feels like my character is stopped by the enemy rather than him smashing into the enemy. It's kind of hard to explain but the skill just feels off when compared to the crusader's leap abilities, or even the Psykers warp sword attack. They seem to have a real feeling of weight and impact, and the sound effect to go with it - unlike shield charge's fizzly, soupy feel.

*Edit - Also appears to damage friendly NPC's, just tested on a storm watcher. Not sure if this is intended? I will also test this next time I go coop with my friend to see if I get stuck/blocked on him and/or causes him any damage.  

Thanks for any responses,

Cheers

This post was edited 48 days ago by Lord Rivendark
Store Page
Share
6 comments
Storm Shield - Shield Charge doesn't always work
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
40 days ago
Waagabond

The build is good, not questioned that? It's just the intermittent issue with the skill that is causing any trouble.


Unfortunately, it still happens even if I'm facing and aiming at a pack of enemies, I'm talking even big swarms that are not in cover. Not every time but it still happens even whilst following your parameters. I play on PC using keyboard and mouse so pretty much always have my cursor targeting an enemy and will be facing them. This also doesn't explain why it causes damage to NPC's.
41 days ago
The build works fine. I played it as well with hammer. Seismic slam plus shield charge, 0 cool down.


Now for the issue you have. This occurs when you have no target and press Shield charge. The ability will be used and locks you in place.

So before you use shield charge, make sure there are targets nearby your aiming at on PC or aiming in their direction on Console. If not, your stuck.

Also if you shield charge and aim at enemies behind cover, this can also occur. 

Once you learn how to ignore this, it happens maybe, once in every 10 missions cause you miss clicked or miss aimed.

45 days ago
Posted by Marcopolocs 45 days ago

Did you experience this both in solo and in coop? What is absolutely sure it should not damage the NPCs. Have you found yet any pattern on why only sometimes does the skill work? 

Hi @MARCOPOLOCS‍ thanks for the reply :) It happens in both solo and coop. Seems to happen more often if block skill is pressed at the same time or being held when shield charge is used - that said I can't be 100% sure it is that as it does just happen randomly, but regularly enough to notice.


I tested the NPC damage on a mission with Caius Thorn and it also seemed to damage him, so it does seem to be damaging friendlies for some reason.

45 days ago
Marcopolocs
@MARCOPOLOCS‍  I see the same behavior as @DEADREI‍ and @LORD RIVENDARK‍  Just thought you are aware of this issue.

Also I noticed that it happens not only with storm shield, but with some mobs as well. Black legion and Khorn jump packs, and 2 nurgle champions, demon with big sword and another dude with an axe, their all skill interrupts and rolls back all the time.


45 days ago
Posted by Marcopolocs 45 days ago

Did you experience this both in solo and in coop? What is absolutely sure it should not damage the NPCs. Have you found yet any pattern on why only sometimes does the skill work? 

I experienced the same issue on rare occasions. I don't play my melee crusader that much anymore, so it's been a while. I think it's a pathing issue when the enemy moves out of straight line between skill button press and skill start? Like when there are two enemies moving - there's a straight line to the target when you use the skill but the target mob "hides" ever-so-slightly behind the other a split second after you use the skill (so there's no more straight line connection when the skill actually starts and your character is supposed to dash forward). Can also break the straight line by terrain obstacles.
45 days ago

Did you experience this both in solo and in coop? What is absolutely sure it should not damage the NPCs. Have you found yet any pattern on why only sometimes does the skill work? 

This comment was edited 45 days ago by Marcopolocs