Repeatable crash - Not enough free ID


After about 19 hours of play using the same character with 0 issues, the game started crashing 100% of the time, after about 5-10 mins of gameplay. Happens on different missions. Single player, has the latest Dec 14 hotfix. PC, Win10.

Store Page
Repeatable crash - Not enough free ID
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
45 days ago

That is great news Marcopolocs, thank you! Can't wait to continue my crusade this evening :)

46 days ago


a third and likely final hotfix has been released on PC to fix the remnants of the ID crash bug. We would appreciate any feedback if you were to run into it once again. Our team would like to express their gratitude for your patience and continuous reports throughout the last weeks.

The Emperor Protects.

47 days ago

Even after the hotfix this error continues, just cannot finish a lvl 90 mission, tried multiple times, the "not enough free userid" crash happens every single time.

Very frustrating as this pretty much prevents me from playing now :(

This comment was edited 47 days ago by Blark
49 days ago
I've been getting this issue very often over the past few days, especially today.  It's hard for me to pinpoint what the cause is, because it happens when I use a grav gun rifle to put gravity wells down back to back, hitting loads of enemies all at once, and my character is built to stack lots of vulnerabilities and on-hit/on-crit effects like poisons and bleeds and slows and knockbacks and stuns.  I'm pretty sure all this stuff happening all at once is just overloading the game systems.  I probably have my very own little folder full of crash report spam stored on your systems somewhere!

This is making it kinda hard to do those level 110 missions without dying, to finish off the season...

52 days ago
I don't believe the issue is fixed. I just began encountering it today - after 140 hours of very nonstop play, without a single crash. I do have Rage/Enrage tokens on my character if that has anything to do with it. This is very frustrating, my build is now non-viable because it crashes the game :(
60 days ago


a new hotfix has just been released on PC fixing the 'Not enough free ID' crash issue. We made extensive tests prior to the update to make sure this time the issue will be permanently removed from the current version of Inquisitor but in case we overlooked something and anyone runs into the problem again please inform us here in a reply or at [email protected] Thanks in advance!

The Emperor Protects.

63 days ago

A new hotfix was prepared to remove the remnants of this crash bug. I will notify you all here once the small patch got released.

84 days ago

P.S. Try not to switch weapons while playing.

85 days ago
I had the same error and crash but for me it was linked to a weapon proc 15% chance to cause enemy to explode.  Game became unplayable and would crash constantly.  After swapping out that weapon the crash seemed to clear.  
85 days ago
Since today, I have also this exact same problem 4 times in a row....

Please fix this, it's ruining my gaming time

87 days ago

After playing this game for 100+ hours I didn't have a single crash or bug. But out of the last 20 missions the game has crashed on about 13 of them with that same message. It did it on the same mission 5 times, so I gave up on it, played a few more missions. Then it started doing it on every one. I tried reinstalling the game, didn't help. The game is unplayable now. 

It would do it eventually, no matter what weapons and such I used. But it would always happen if I used "Compressed Plasma" followed immediately with "Phosphorous Splash" while the shock aura is active.

P.S. This sucks, cuz I'm way into this game right now

This comment was edited 87 days ago by Horge
88 days ago


Are you using Shock by any chance?

Once I switched my build from Shock to Slow the issue has mostly resolved.

It did repeat once when casting Slow+bleed AoE on a pack of Psioli.  They pack close enough together to proc a lot.  I have screenshot of the crash for reference of all effects and buffs visible.

This comment was edited 88 days ago by Lollipup
89 days ago
I am having the same issue. I am playing an assassin sniper with shock on crit, the psalm that causes explosions when shocked enemies die, and using the armor skill that creates two holograms with my weapon swap which is an arc blade.

As i understand it shock has often been cited as an issue.

I can reliably reproduce this bug. It happens whenever I play the unholy cathedral and get to about 7 minutes and 30 seconds. The game crashes and I get the Not enough free ID error. When I open the game again I am left with no reward from the time spent.

My specs are as follows:

Ryzen 9 3900x

32gb RAM

1080ti GTX

Windows 10 64 bit

The game is installed on a brand new SSD, which is not close to being full

I am playing the game on my 4k TV with all graphical settings maxed. 

I usually get 60 FPS (capped via vsync) but sometimes drop to 45 or 50.

Unholy cathedral is the only place where I get this error so far. But I only recently swapped to this shock heavy set up. This is a really disheartening bug as I am concerned of losing more progress, void shards, etc. by playing this build.

Devs please contact me and I will help you, as I can reproduce the bug. I would like to volounteer to help solve this.

89 days ago
I am having this same issue now.  Twice in a row today plus once last night.  

In the middle of crusade missions and unable to progress, I am not using an AOE when it happens though.  I am happy to help fix this bug if the Devs wish to pull data from my account? 

91 days ago

A month later, I am having the same issue on regular, but unrepeatable, situations.  First mission after computer restart.  

Psyker using a heavy knockback/shock crowd control build.

The most common noted factor is that it happens during an enemy:mech mission.  Seems like it may be an inconsistent error with aoe/knockback/knockdown on the robots that are immune.

EDIT:  happened 3 times, 3 attempts in a row.  Data hunt mission, ebony crusade, right of bottom center.  Seems to be when hitting large groups with AoE crowd control on robots.

I replaced my shock runes for slow runes.  Made it through the mission. 

-Issue may also include the shock proc and Nova/Volkite/Transonic psalm code ("Killing a Shocked enemy creates an explosion causing Shock and dealing damage equal to Damage from the killing blow").  If that chained on enough of the Mechs, I could see attempting to proc too many effects in a very short time with AoE on large groups.

This comment was edited 91 days ago by Lollipup
124 days ago

Have any items "the FEAR on hit" enchantment?

Do you occur enemies with a negative value of suppression?

This comment was edited 124 days ago by MiraLyx
124 days ago
Aren´t you supposed to get a pop-up window after Crashes that tells you Yes/No to send this info to Neocore immediately?

Just asking since that is the case for me on a couple of occasions.

124 days ago
Bumping for visibility. @MARCOPOLOCS‍ 
126 days ago
I just completed the mission (inner sanctum, the one where you collect information, the video fragments) by using a ranged weapon, avoided getting surrounded and didn't use the suppression shield discharge AOE. This suggests that the bug is related to the AOE/surrounded procs. 
126 days ago

The character I am playing is an assault Crusader with melee focus. It started happening recently, I am not sure about the exact circumstances but I suspect it has something to do with being surrounded and doing large AOEs like the suppression shield. I have a few procs that are related to being surrounded on gear as well. So maybe it has something to do with that. I tried 4-5 times on the same mission, it always happens at a certain point. Also happened in a different mission. Maybe there is an ID leak somewhere that manifests itself under very specific circumstances. I'm happy to share data/save files with devs if that helps track this one down. 

I'll experiment a bit with gear and skills but it is a time consuming process...

126 days ago
Hi there. If this is indeed repeatable, it would be great if we could get more information on your situation. I'm not exactly sure what info is most useful for the devs, but they may be able to pull some of it directly from your account. Maybe Marco can get in touch with the right people to figure that out. He may have you email details to them.

This bug has been popping up infrequently for a few months at least. It showed itself even before S2, but there were also a few occurrences during beta testing. The problem was always that it was extremely hard to recreate (and thus diagnose). The few of us who'd experienced it attempted to artificially trigger the circumstances, but we never had much success. Nominally it should be totally unreasonable to get anywhere close to the ID limit (which I think I remember being told was 4096).

I'll let the Neocore folks speak for themselves, but if you really have stumbled across a situation where it's happening all the time... well, actually I'm sorry to hear that... BUT the silver lining is that you may be in the unique position to be able to help the entire community rid ourselves of this bug once and for all!

Here's to hoping, and I do hope they get you sorted out soon.