Can't finish missions


Hello there!

I really enjoy "Inquisitor - Martyr", but the game crashes nearly every time, when I'm about to finish a mission. First this show up:

Then the game shut down, and show this message:

Tried every kind of mission, to install new, cry a lot, but nothing helps so far.
Hope for quick help!

MfG from Austria!

Store Page
Can't finish missions
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
49 days ago
after patch, everything is working. No crashing. Thanks!!!
69 days ago


Our team prepared a new hotfix to PC which should entirely remove the 'Not enough free ID' crash bug. We will push the update out as soon as possible (hopefully today) and would like to ask you to check on the game after that to see if the problem is still present.

We would like to apologize for the caused inconvenience.

74 days ago

I stuck to just one weapon and was able to finish a ordos mission without crashing. Have to try a few more. Not a great workaround. Missing switching. But at least could complete the mission. Thanks

This comment was edited 74 days ago by miflin
80 days ago
The game works better now, but I finished a whole crusade, and the game crashed while i opened the chests. And the crusade is considered lost, so it didn't count for the Warp-saison-tasks...
83 days ago

I stopped switching weapons and the problem disappeared

85 days ago

Still ongoing. I have given up trying to complete the Ebony Void Crusade. Only have the final ones to do and tried all three and crashes on any one of them with this error. One that got me last night, I know glutton for punishment, I tried a Ordo Malleus, got all of the gates destroyed, etc. Mission Accomplish came up and before I could hit Quit, error :( and lost it all. Like the hour I spent was in vain. I use 2 handed grav gun switch with hammer and shield. 

97 days ago


We are still working on this problem and are collecting even more information on the matter. We would like to ask you to share your own experience under the following Steam thread:

We will be grateful for any input you make!

98 days ago
Same problem, can't finish a mission now. This problem happen 4-5 minutes after i start a mission and it's happening in every mission.
99 days ago

This is how I play every day. And this happens at the end of every mission.

This comment was edited 99 days ago by Austerlic
99 days ago

Today I decided to check the game and lo and behold, I went through three missions without crashes. Then I decided to go through the Intel mission. I passed it and I had only to press the button to complete the mission, but the game crashed! Arrr, how angry I am!

100 days ago
Joined the community to report a crash and issue was not my intention, but here it goes..

a few days ago, at the Loot Box area of a Mastered Supreme Void mission, while i was clearing my personal stash to make room for the loot, the game crashed on me..

when i logged back in, it told me i have completed the Void Crusade.. but all the loot was gone, even the items on my character..

i hope u guys could fix the issue asap mate.

102 days ago

We have been waiting almost a month for this error to be fixed. First time like this. I bought it, but I can't play.

102 days ago
same here. cant finish my crusade or a endless tide. 

reducing corpses in the option had no effect.  crash always about the same time / area
103 days ago
I have the same crash, "not enough free ID". It has occurred on two campaign missions so far. Took me three or four attempts to get through the mission where you meet Flavius Draken and just now it crashed on the mission where you have to defend the anchor engines.
104 days ago

I confirm. I flew out in 5 minutes in the morning. (Void Crusade). I really want to play.

105 days ago

Problem still exists. It is not possible to play.

106 days ago

Completed 3 different missions. I was already delighted, but on the fourth (void crusades) mission + 203% I took off with an error.

107 days ago
We are working hard on these, sorry for troubling everyone here. We will be as fast as possible in resolving the issues appeared lately!
108 days ago

Yes. The game started to crash more and more often. This can happen at any moment.

108 days ago
Game crashed when i was just putting items into trashcan in my inventory with my lvl 5 char..  This error's not just enchant or skill or mission related anymore.
110 days ago

At void crusades activated with crimson and ebony void shards. But i completed a ivory void crusade without any problems. Sometimes the game shut down at intel missions too.

112 days ago

I turned off the antivirus. Reinstalled the video driver. I changed weapons and equipment. Skills. Refused various trips. I thought it was just crusades. No. This can happen in any mission. Yesterday I went through 3 missions in a row and thought that I found a way out. But no, it jumped out on the intel mission. This is terribly annoying. Win 7 64 bit Ult. Geforce gtx 1080 CPU Intel 4770k. It started right after the last update.

112 days ago

@MORATIO‍ could you please tell me in which missions and crusades did you run into this bug?

112 days ago
I updated my graphic card, lowered the graphic's and gave up at the crashing mission's and crusades.

It works now, but I'm still nervous with every lagg. Hope thats helpful!

112 days ago
It is not possible to play. It got worse.

115 days ago

I can't finish for a week voide crusade. 

117 days ago

Have the same issue here too.

120 days ago

I have the same. Can't finish my trip. This is very irritating.