Tech Adept 3rd Passive [Known bug and fixed in development branch]

2

I recently picked up a second copy of this game and am doing a play through with the Tech Adept on PC. I fully beat the console version (and am waiting patiently for that sound fix) so it wasn't a difficult decision to pick it up. Problem is I got so used to playing it via controller that the mouse/keyboard just felt *wrong*. LOL! (I know heresy...) Anyway I got to the part that unlocks the 3rd passive and imagine my surprise that if you attempt to select the 3rd passive square it **actually** highlights your characters detailed specs list on the right in that menu. Unfortunately there is nothing you can do about it except quit to the menu, disable controller support, load back in, set your passive, quit to menu, enable controller support, and then you are good. I did not try to change the passive once it was already set and will report back in a bit if that's possible.    (Quick edit: Once set it does select the actual passive box correctly.)

[BUG: Tech Adept (possibly other classes) cannot access the 3rd passive screen with a controller. When the blank 3rd passive is clicked it opens the character specs on the right.]
[PC Steam "Martyr" executable version installed]
[All DLC installed]
[Windows 10]
[Xbox One Controller]


Also, is there an engine reason or something odd that enabling controller support completely disables the mouse/keyboard? And is this why you have to go all the way back to the main menu to enable/disable it? Seems odd you can't just enable/disable within the actual game because the load times on this game are not exactly short. LOL    

Hope I did this right with as much information as necessary to duplicate the scenario. 

This post was edited 44 days ago by Laquox
Store Page
Share
2 comments
Tech Adept 3rd Passive [Known bug and fixed in development branch]
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
44 days ago
Posted by Marcopolocs 44 days ago
The problem you mentioned got fixed just the other day in the internal build and the next PC update will contain the fixes.


The ingame enable/disable mode is missing due to technical reasons, yes. It would be a cool addition though, I will bring this up whether we can do something about it. Thanks for your feedback!

Excellent! Nice to see there is on going development and the team is open to ideas! Keep up the awesome work!

44 days ago
+1
The problem you mentioned got fixed just the other day in the internal build and the next PC update will contain the fixes.


The ingame enable/disable mode is missing due to technical reasons, yes. It would be a cool addition though, I will bring this up whether we can do something about it. Thanks for your feedback!