Ps4 inquisitor martyr chapter 2 glitch


Ive got a bug on chapter 2 where it shows 4/5 clues for saving thorn but no chapter mission is showing for me in the sector. Username: Lord_Balin character: Lord_Balin

Store Page
Ps4 inquisitor martyr chapter 2 glitch
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
19 days ago
We could not reproduce this problem just yet. Could you please give the mission another try to check if you can proceed further on the second go?
24 days ago

I have a problem I bought the expansion prophecy and in the mission the "martyr" the door that has to be opened when canceling the security door does not open at all I need help with that I spent 20 euros on this dlc my user is riverogregory18 and my character is called TecNoctis

24 days ago
This comment was deleted 19 days ago by Marcopolocs
56 days ago

The issue has been fixed please check your character's progress.

59 days ago
I've finished the quest 4/5 and at the end of the mission told me to go to one of the 3 locations to continue thing is the mission is the  third location I went to. 

PSN: Forsaken_Lucifer

Class: Assassin

63 days ago
All 3 characters' progress has been fixed just now. Thanks for your patience in the last few days!
65 days ago
I have the same now on my sniper assassin 

Username  D1zz1us

68 days ago
I am also having this problem.

My psn is The_Mandowarian

Character name is same as psn

68 days ago
Problem solved when I started a void mission?
68 days ago
Stuck chapter two hunt for the martyr
Character: assassin
Name l00kint0meeyes-2


And honestly, how can this still be an issue after over one year?

75 days ago
77 days ago

My friend on ps4 is very bug at this quest, anyone help for this?!

ps4 : mama182005 - name character : Mediora 

Hope you can help him? Thanks!!!! (:

78 days ago
I have this issue now as well.

Codewrite on PSN

202 days ago
The issue got fixed on our end please check on your character's progress when you've got some time.
208 days ago
I am also having this issue with my game 

platform ps4 

gamertag Fightingtoddler

236 days ago
Posted by Mardo 237 days ago

Found this thread as I'm having the same problem playing on PC. Pity, I was enjoying the game immensly. Player/character name mardavrio

False alarm, I figured out what I had did wrong. I hadn't seen the alternate menu for choosing missions etc. Wasn't obvious as other missions had been previously gave to me rather than using a new menu option to continue the campaign maps.

237 days ago

Found this thread as I'm having the same problem playing on PC. Pity, I was enjoying the game immensly. Player/character name mardavrio

This comment was edited 237 days ago by Mardo
239 days ago
Im haveing the same bug gamertag THE ROGUE59
239 days ago
So I'm having the same issue on pc. I just talked a friend into purchasing the game so we could play together and I can't advance in the campaign to continue playing with him 

My character name is Ross al Ghul 

If you could help that would be awesome. I just want to continue playing and would really really rather not start over 

253 days ago
I am having this same bug issue —rickfury0055
254 days ago

My friend and I have the same issue. Please fix our accounts.chaosboyz666 and SuperDuckman13.

266 days ago
you are the best!

everything is fine now

many many thanks =)

266 days ago
Could you please check your character' whether it can advance now? We just fixed the issue.
267 days ago

Hello Support Team,

i have the same Issue but on the PC Version.

Char: Dante

thanks in advance!

308 days ago
Thanks man!!

It works. Wondurful!

Stay safe!

308 days ago
Please check on your Psyker character. Can you proceed in the campaign now?
309 days ago

Im also stuck to in the search. Cant find the third planet to search on.

315 days ago
Thank you, looks like it's now resolved.

Have a good one, Marcopolocs!

315 days ago
Could you please check it now? It should work this time.
316 days ago

Dear @Marcopolocs, unfortunately my problem of being stuck at Chapter 2, Saving Caius Thorn at 4/5 clues for the Magos Biologis is still not resolved. PSN: Jack_of_swords Character: Aradiel

Many thanks!

330 days ago
This comment was deleted 329 days ago by Marcopolocs
337 days ago
We resolved the problem please check on your character.
339 days ago

I'm also having the same issue. 4/5 complete. Been to all the locations (in a multiplayer game), but not able to progress.

I'm on PC, though...

This comment was edited 339 days ago by RiceRocketeer
348 days ago
It works now, thanks!
348 days ago
We fixed the issue on our end could you please check your character?
349 days ago
I have the same bug as well, it just hit me the other day.

My psn handle is strangeloven, any help is appreciated.

354 days ago
We handled the reported issues, please check on your characters when you have some time @STORMWARD@CYNICALJESTER‍ 
355 days ago
Hi, i am also having the same issue, any help appreciated 

IGN: Stormward

Cara: Stormward

355 days ago
I thought this might be a quicker way to get your attention. 

I'm having the same issue.

My psn is: Blaine-63

My character name is: Cynical Jester

Any help would be awesome.

355 days ago
Hey I'm experiencing this glitch is there anyway you could fix it for me aswell please? 

My psn is: Blaine-63

Character name is: Cynical Jester

Any feed back would be appreciated., thank you. 

1 year 10 days ago

I am also stuck on the same mission. Been to all 3 locations. On PS4 gamertag ReaperOfDoom25

1 year 10 days ago
Hello, I am also stuck on Chapter 2, Saving Caius Thorn, Search for the Magos Biologis. I have searched all 3 locations but it isn't registering. I'm on PS4, gamertag is Ogdred1. 
1 year 11 days ago
Hello! I am loving the game so far but ran into a bug as well in chapter 2 and cannot progress. Please help!

PSN - StrublesNBits

Character - Stabby McShield

Thank you for all your hard work!

1 year 16 days ago
We fixed the problem you ran into. Please check on your character and let us know if you still have any trouble with it.
1 year 17 days ago
i have the same issue can you please re set so i continue on my journey
1 year 34 days ago
@QIDOO‍ we fixed the issue on our end please check on your character.

@REKS616‍ could you tell us whether the issue is still present on your end?

1 year 37 days ago

Hi, i have the  same problem in Chapter 2 i have 4/5 clues and no further mission 


1 year 38 days ago

Hi, i have the  same problem in Chapter 2 i have 4/5 clues and no further mission been to all 3 locations.

psn: QuiDoen

1 year 48 days ago
At the time you reported the issue we checked on your account and handled the problem. You are saying you've still got the same problem?
1 year 51 days ago

iIm still waiting a response regardless my case. I want to play the game, how long will gonna take it?