Game Crashing on Xbox

9

So I see a lot of people having this issue as the Tech Priest, but I haven't even played as him. My game will randomly crash back to the Home Screen as I'm loading into a level. I've watched it happen to my Wife while loading into a level as well. I play as Crusader and a Psyker, My Wife plays as an Assassin...

I wouldn't be posting this, but it has happened a number of times and now we're both fearful to play co-op... Any advice or work-arounds would be AWESOME! 

Tank you Neocore-Peoples!

Store Page
Share
9 comments
Game Crashing on Xbox
Your Thoughts? Please login to place your opinion. Not a member yet? Register here and now!
107 days ago
MasterCross10
Well oops!! Read too quickly xD


Your crash is related to the ancient relic gear which is orange then, just put that into storage and you should be fine!   Such a idiot I am xDDD

107 days ago
Satan707
It's funny... I DIDN'T play as the Tech-Priest, I hadn't even touched him because of all the bugs I had read about. But I felt bad that you had gone out of your way to find this fix and took time to comment on my post. I made a Tech-Priest and am now playing as him and he's actually a lot more fun than the Crusader lol.

Thank you Satan! Lol

107 days ago
Satan707
Well I would... But as I stated in the post... I don't even play as the Tech-Priest... I'm a Crusader...
107 days ago
MasterCross10
Constructs are your summomed machines, you must make sure every item they have is removed, even having just 1 module or weapon equipped will make your game crash, let me know if this works 
107 days ago
MasterCross10
No no much easier than that!  When you're on your bridge to the right side you will see 'Construct Setup' go on that and remove all equipment of weapons and modules on your construct and once you do that the game should load your multiplayer game, your character equipment should be fine.
107 days ago
Satan707
This may make me sound really kinda dumb... But.... What do you mean by "Constructs"? Like the characters? Because that would kinda be a pain to unequip my whole load-out just to have to re-equip everything. Then rinse and repeat the process before loading into every level. 
108 days ago
+1

Thank you for reporting this and providing valuable details. We will check the constructs' equipment immediately!

This comment was edited 108 days ago by Marcopolocs
108 days ago
+1
Just did another test, it definitely appears to be the equipment of the constructs, removed all equipment after crashing and I'm able to play multiplayer again
108 days ago
+1
I think it's something to do with the summond creature equipment, I just salvaged everything and it loaded, bot exactly a great work through but it's been the only way I've been able to play online